Nvidia Steam Coredump on 535.54.03

The newest nvidia drivers on arch linux are causing steam and games to immediately core dump

Jun 16 15:25:34 archdesk systemd-coredump[1649]: [🡕] Process 1456 (steamwebhelper) of user 1000 dumped core.

                                                 Stack trace of thread 1456:
                                                 #0  0x00007fc2311db794 n/a (/home/jrgiacone/.local/share/Steam/ubuntu12_64/>
                                                 #1  0x00007fc231267522 n/a (/home/jrgiacone/.local/share/Steam/ubuntu12_64/>
                                                 #2  0x00007fc23126a764 n/a (/home/jrgiacone/.local/share/Steam/ubuntu12_64/>
                                                 #3  0x00007fc218cf77f2 n/a (libnvidia-glcore.so.535.54.03 + 0x14f77f2)
                                                 #4  0x00007fc2187fcf45 n/a (libnvidia-glcore.so.535.54.03 + 0xffcf45)
                                                 #5  0x00007fc21880844a n/a (libnvidia-glcore.so.535.54.03 + 0x100844a)
                                                 #6  0x00007fc218b46182 n/a (libnvidia-glcore.so.535.54.03 + 0x1346182)
                                                 #7  0x00007fc218b49cb5 n/a (libnvidia-glcore.so.535.54.03 + 0x1349cb5)
                                                 #8  0x00007fc22ccbac25 n/a (/home/jrgiacone/.local/share/Steam/ubuntu12_64/>
                                                 #9  0x00007fc22ccbafae n/a (/home/jrgiacone/.local/share/Steam/ubuntu12_64/>
                                                 ELF object binary architecture: AMD x86-64

note downgrading to 530.41.03 allows it to work

Any one else having this issue, xorg nvidia 535, steam will not display its window, may be new to the web gpu they implemented


Yes I’ve this issue too. But the Nvidia Devs are aware of this bug and are actually trying to fix it.
Waiting for the problem to be solved, you can still use Steam on the 535 drivers. Open steam through a terminal with the following command:

steam -vgui

This will open your updated version of steam but with the old interface. When the issue will be resolved, you will be able to open steam via the traditional way.

I’ve been getting around it this way too, however the friends list is unavailable when doing it this way. Have you run into this issue?

Clic “contacts and chat” at the the bottom-right on the Steam window. If i do that, the little box with the friends list appear.

yea it pops up but says network is unreachable or fiends are unavailable something along those lines

My bad, you’re right, I don’t play online very often and I was offline. I tried to connect and like you, that say “network is unreachable”.
Sorry but I don’t have a solution right now for that.

So yes, you have 2 solutions:

  • Stick with the 535 driver and the old Steam interface and also the contact list unavailable
  • Downgrade to the 530 drivers and having a fully functional Steam

Personally, since the 535 release fix number of games that crashing with older drivers and since I don’t play online very often, I will stick with 535. But for those who play online with their friends, downgrade to the 530 is the only way.