Nvidia vGPU license server issues only two licenses


sorry for my bad english.
We are currently supplying one of our customers with an RDHS-Windowsserver22-Enviroment which accesses GPU ressources.
We have ESXi Hosts with the NVIDIA A40.
We issue the licenses cia CLS. We have 70 vApp licenses.
In the beginning the licenses were obtained successfully by the user sessions. But now since some days we there are only 2 licenses requested althoug there are more user sessions. Per server one license instead of per user one license, so to say.
I tried to troubleshoot the problem by looking at the Nvidia Licensing Log.
It says that the licenses can be obtained etc. But still there are only 2 vApp licenses issued.
Before the problem occured, u could see down right a message which says nVidia license successfully obtained.
But now this message does not show up.
I checked network-connections etc.
Everything looks fine.
And also there are 2 licenses which are obtained. One per Server (We have 2 RDSH which accesses nVidia Ressources)
I also restarted the service. Without any success.
any ideas ?

it works exactly as it is designed to work and it is impossible that it ever worked the way you described.
vApps licensing is not license enforced (EULA based) so only the host itself gets a license as we cannot count the CCU at this stage.

Best regards


thanks for your reply. That might be true it is some weeks ago.
BUt still, there should be more used licenses than this, right ?
There are right now at least +20 User-Sessions per host and still, only 2 licenses were obtained:

The vPC License was never used. I swear whenever i loggend in with an test-account, i saw the message down right that a nvidia license was obtained.
And as shown in the screenshot, a lot more licenses were obtained. Now i have only 2 that are in use while +30 user are logged in. I my understanding somewhere wrong ?

If you have 2 hosts (RDSH) then you should have 2 licenses assigned as only the host acquires a license.
You will need the CCU count to properly license the use case but as I said already this is EULA enforced.

You will need the CCU count to properly license the use case

we assigned all the licenses to the CLS instance:

And again, more license-usage was shown in the past.
Is the CCU count a feature that i accidently disabled or didn’t enable at all?
Because licenses were allocated successfully in the past.
It might be right that only two licenses are obtained, one per RDHS host. But again the usage should be way more (depending on logged in users).
Do you understand what i am trying to explain (english not good)? If my understanding is correct, your statement is that my described scenario is a feature and not a bug.
I also opened a NVIDIA ticket.
Thanks again for your time.