Nvme gpt storage size

logs (30.2 KB)
serialcom_logs (53.3 KB)

I’m trying to flash the Jetson Orin NX with an external NVMe ssd card (32GB) with the following command: sudo ./nvsdkmanager_flash.sh --storage nvme0n1p1

It is a custom carrier board, but it worked with the Jetson AGX Xavier before without the external boot storage. The logs basically say:
→ the xml indicates the gpt is larger than the device storage.

Now I’m not sure which file to change storage size in /bootlader/t186ref/cfg.

Hi Meditiari

Do you mean it could work with Jetson Xavier NX?
If yes, it seems the custom carrier board similar to p3509 carrier board.

Do you get the custom BSP package of JP5.1.1 from vendor?
Please use the following command to flash the board.

$sudo ADDITIONAL_DTB_OVERLAY_OPT="BootOrderNvme.dtbo" ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
-c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
--showlogs --network usb0 p3509-a02+p3767-0000 internal

Ok thank you. Yes, it’s a carrier board designed by ourselves and it worked fine with the Xavier NX. It even worked with sdkmanager without changing anything.

I tried the command you provided but now I get the log:
Error: Could not stat device /dev/nvme0n1 - no such file or directory.
flash failure.

The command for Jetson Orin NX described here below gives me the same error as my previous described flash command. → the xml indicates the gpt is larger than the device storage.


sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 jetson-orin-nano-devkit internal

But with both commands I provided the jetson Orin boots and I can connect and work on it with minicom.

if I do fdisk -l on booted device I see:

The primary GPT table is corrupt, but the backup appears OK, so that will be used.
Disk /dev/nvme0n1: 27.98 GiB, 30016659456 bytes, 58626288 sectors
Disk model: SFPC030GM1EC1TO-I-5E-A16-STD
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 6C5311D7-7361-460B-B699-5B3CEEF288F0

OrinNX+p3509 is not supported in SDK Manager.
If you can use SDK Manager to flash the Xavier NX+carrier board, it means the pin define really similar as the devkit carrier board(p3509) due to using the board config of the devkit.

Have you formatted the NVMe SSD as ext4 before flash?

Yes that was the plan to design the carrier board to match the same pins.

No, I tried it with Jetpack_R35.2.1 as described in this post:

How to flash Jetson Orin NX 16GB moudule - #11 by alexandru7ac9a

Got the exact same error and one guy said formatting the SSD to EXT4 solved it. So I will try that, thanks.

So I managed to flash and boot from a 512GB SSD which I formatted with EXT4 and where the <num_sectors> on the SSD are big enough. With the 32GB SSD it still doesn’t work, even If I adjust the <num_sectors> in the file:


Then I still get the error:
→ the xml indicates the gpt is larger than the device storage.
Is there somewhere else I should adjust the <num_sector> size?

I managed to flash the 32GB SSD with this command:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
-c tools/kernel_flash/flash_l4t_nvme.xml -S 16GiB --external-only --showlogs jetson-orin-nano-devkit nvme0n1p1

With changing the <num_sectors> in tools/kernel_flash/flash_l4t_nvme.xml and -S 16GiB as additional parameter.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.