Problems flashing the AGx Jetson Orin


I am contacting you to ask you for support about the documentation related to one of the NVIDIA Jetson modules, the Jetson AGX Orin 64 GB Developer kit (P3701-0005 moduleP3737-0000 carrier board).

I’m trying to flash the Jetson on an external NVMe 3 Gen x4 to expand the storage capacity. I set the module in recovery mode following the official NVIDIA page instructions, then I tried using the Nvidia SDK Manager Package and Linux Terminal commands using ./ from GitHub - jetsonhacks/bootFromExternalStorage: Shell scripts to setup a NVIDIA Jetson AGX Xavier, Xavier NX, AGX Orin, or Orin Nano Developer Kit to boot from external storage. repository. It has taken a long time and I still receive the same errors for both SDK manager and Linux Terminal (I attached images).

Is there a command that I can use on the module to prepare it for flashing it from an external NVMe? How can I troubleshooting this issue?

Thank you for your attention; I am waiting for your answer.

Best regards.

This script is not even made by NVIDIA…

sudo ./tools/kernel_flash/ --external-device nvme0n1p1
-c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml”
–showlogs --network usb0 jetson-agx-orin-devkit internal

Hello @DaveYYY.
I appreciate your quick response. I keep having problems. When I follow the instructions I get the next error:
Error: Invalid target board - jetson-agx-orin-devkit.

However, I tried using Nvidia SDK Manager again after following your instructions and this time it worked.

Thank you so much :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.