NX DOes not boot completly

Using a previously configured Kernel I Commented out the PPS DEBUG

# CONFIG_PPS_DEBUG is not set

I then rebuilt the kernel and image then flashed

make ARCH=arm64 O=$TEGRA_KERNEL_OUT -j2
 copy files to correct spots
sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

After the system is flashed the system boots and asks the question, then updates file bar, then nothing else. no desktop only the background.

Please use the uart console to check if the system really not boots up or just the desktop fails to launch.

  1. At poweron the L4T readme directory does show up and get be access throughout.
  2. Pinging gets no responce
  3. ssh nvidia@ does not connect
  4. Putty to the Com port at 115200/8/1 gets no responce.
  5. At power on, I tried to ping and got two replys .

I go thru the normal setup questions, but the one for WIFI does not get asked.

The system has the “System Setup” bar for keyboard and HW, etc then nothig happens, just stays at the UBUNTU background.

  • The Mouse still has a cursor.
  • ctrl alt T does not Bring up a terminal
  • there is a power icon in the top right corner that can be clicked to drop down, but no resonce if the power button is clicked.

When I power cycle the NX, It is back to Ubuntu initialization. Only thing cashed is computer name.


Just want to clarify, if the “COM port” you are using here is based on this?

Also, we can switch to some other ways to validate this issue.

First, please directly flash your NX board with just default BSP from sdkm. Everything should be fine under such setup.

Then, put your new kernel image with the setting CONFIG_PPS_DEBUG to /boot/Image on NX, reboot the device and check what is going on afterwards.

Nope, Com port is the micro USB used for reprogramming. I am on a NVIDIA Development carrier board with a Production NX.

I will try the reprogramming.


Please use the serial console from uart instead of the micro usb. The log out from these two are different.

OK, I have a NX Not a NANO. Is the console on the NX dev kit J12 8 and 10 (UART1)

Please check


Hooked up FTDI to Console J14 3/4 no reponce to CR.

I did notice during boot a dmesg: failed to create volatile files and directories on the HDMI screen.

If you can see something on the monitor, then it is setup problem on the uart console.

UART will print the log since bootloader. It is unlikely to see nothing from it. To be honest, even the worst case has uart log too.

Console problem was with carrier.
Swapped to different carrier.
I now get console output. Last line is:

[    9.314455] Please complete system configuration setup on desktop to proceed.                ..

I completed the configuration.
Here is the full output to console.
startupFailConsole.txt (40.0 KB)

I’ll try loading a known good on the NX then load image like you suggested.

I used SDK manager to load flash the board and that worked.
I then flashed just a known good system.img to the APP partition and that worked.

Just tried rebuild and flash same problem. I did noticed That during configuration I am not asked to configure WIFI. I am on other builds.

Just deleted the kernel_out directory and rebuilt from scratch.

I still get the same halt waiting for configuration to complete.

The configuration does not ask to setup the WIFI, which it did on good build.


Please help share your detailed steps to build kernel.

Also, another method to dump log, before you flash the board, go to Linux_for_Tegra/rootfs/boot/extlinux/extlinux.conf and remove the “quiet” from it. This will dump more log on the uart in your first configuration.

Detail steps to build (from history)
buildCcommandsHistory.txt (2.5 KB)

Log of startup.
startupPutty.log (114.3 KB)


I see some gpu error in the last few lines of your log. Could you check if this comes out after you tried to do the system initialization?

Also, may I know what is the exact diff between your kernel and the default kernel from jetpack?

It did come out after I started answering the system init questions not sure exactly when. I am reflashing using a saved VM. so can not verify exactly when for awhile.

I have made four changes to the default:

  1. enabled PPS
  2. enabled SPI. This did not work until I used the nvidia tool to enable.
  3. enabled SD 3.
  4. disabled PPS debug. This is when things failed.

I can get you exact changes if you need them.

I did each of these steps one at a time. each worked until step 4. I did back this out but no change.

Question: Could the SDL manager have updated something to cause this problem?

  1. Are you talking about “sdkmanager”? There is no “sdl manager” here. BTW, actually sdkmanager does not work well if you run it over a VM. More precisely, we don’t support sdkm on a VM.

  2. I think you didn’t share lots of detail we need here. So I would like to ask them first.
    a. What do you mean enable “SD3”? Sdmmc3? Is this a nv devkit or your custom board?
    b. If you don’t change anything in kernel, would you hit any error?
    c. If (b) is true, could you change things one-by-one instead of changing them altogether so that we can know which change is causing the error?

  1. I am talking SDK Manager. I do not use it for flashing.

a) it is sdmmc3, I am using a Production NX on DEV kit carrier.
b) No errors on builds.
c) I changed one of the items at a time, each worked with no build errors.
The problem occurred when I commented out the PPS debug. No build errors.


  1. If you didn’t use sdkmanager, then why do you think it is related to your issue?

  2. This may not be related to your issue but why do you want to enable sdmmc3 on devkit carrier board? It does not have a physical sdcard slot on it.

  3. So can we make a conclusion that this issue is triggered by removing CONFIG_PPS_DEBUG from tegra_defconfig?

  4. If (3) is true, why do you want to remove this from defconfig?