Optical HDMI Cable Not Detected on Manjaro/RTX 3080

Hi all,

I’ve run into a pretty interesting problem. I have a computer running Manjaro Linux (KDE Plasma Edition) with an RTX 3080 installed. Currently, all three Displayport ports are in-use for a triple monitor setup. Today I attempted to add a fiber optical HDMI cable to the final port on the GPU, running to a TV. However, the TV shows no signal from this cable.

Exact RTX 3080: MSI GeForce RTX 3080 SUPRIM X 10G

Exact Cable (50ft version): https://www.amazon.com/AmazonBasics-High-Speed-Fiber-Optic-Cable/dp/B07X1KP66Y/ref=sr_1_3?dchild=1&keywords=fiber+optic+hdmi&qid=1635223879&sr=8-3

Troubleshooting I’ve tried:

  • Ensured all packages are up-to-date
  • Confirmed the HDMI cable+TV work on another computer
  • Rebooted the problematic computer
  • Unplugged and replugged the HDMI cable (at both ends, both while the computer was on and off)
  • Checked nvidia-settings (monitor is not shown there)
  • Checked xrandr output (HDMI is shown as disconnected even when plugged in)
  • Tried a different Linux distribution (PopOS 21.04 Nvidia edition)

My two leading hypotheses are:

  1. The GPU’s HDMI port is not working for some reason.
  2. OR there’s something special about a fiber optical HDMI cable?

Attached is my nvidia-bug-report.log.gz file.

nvidia-bug-report.log.gz (286.1 KB)

Any help or guidance would be much appreciated! Thank you!

Seems there’s a general problem with those on RTX3xxx gpus:
https://www.reddit.com/r/nvidia/comments/ja5ro5/compatible_issue_of_hdmi_21_optic_cables/