Optimus; No screens found

I tried to get Nvidia Optimus working on a friends Dell Inspiron 7000 but failed doing so.

The system is running Linux Mint 16 (Linux Kernel 3.11) with X Server 1.14.3. I tried it with Nvidia drivers 319.32 (repository) and 331.20 (Nvidia homepage). Both end with a similiar “no screens found(EE)” error message.
Fyi: The 319 failes due to an “input/output error”, the 331 for “Screen(s) found, but none have a usable configuration.”.

Please see the log files for the 331.20 driver configuration. The driver is installed, nouveau driver is deinstalled, the system has been rebooted.

Has anyone an idea on how to proceed?

Logs:
lsmod: http://pastebin.com/C44uzdkb
lspci: http://pastebin.com/qPUdU5cX
xorg.conf: http://pastebin.com/BbKsNXMG
X Server: http://pastebin.com/BCJcd4Lv

Regards,

Andy

See dmesg. If there are NVRM messages like “rm_init_adapter failed” or “GPU has fallen off the bus”, you may be seeing a weird bug on 3.10+ kernels that may be worked around with rcutree.rcu_idle_gp_delay=1 on the kernel command line.

Plz repro the issue and attach nvidia bug report