Nvidia GeForce 740M and Intel 4000 HD (Optimus)

Hello! I have HP Pavilion laptop with two videocards: Nvidia GeForce 740M and Intel 4000 HD. My system is OpenSuse 13.1 and I try corrently run my system with Optimus. What I did:

  1. Installed latest Nvidia driver from official repo.
  2. Created /etc/X11/xorg.conf with content from this http://us.download.nvidia.com/XFree86/Linux-x86/319.12/README/randr14.html.
  3. Created ~/.xinitrc with follow content:
    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto
  4. And reboot

When my system started, 3 seconds I see OpenSuse logo and then black screen.
I’m switched to tty2 and grep errors:

denis@linux-ghz7:~$ grep EE /var/log/Xorg.0.log >> ~/Xorg-errors.txt
denis@linux-ghz7:~> sudo /sbin/lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)
denis@linux-ghz7:~> grep -i pci /var/log/Xorg.0.log
[    17.629] (--) PCI:*(0:0:2:0) 8086:0a16:103c:2166 rev 9, Mem @ 0xb5000000/4194304, 0xc0000000/268435456, I/O @ 0x00006000/64
[    17.629] (--) PCI: (0:10:0:0) 10de:1292:103c:2166 rev 161, Mem @ 0xb3000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00003000/128

Help me to fix this problem. Thanks in advance
Xorg-errors.txt (682 Bytes)
xorg.conf.txt (669 Bytes)

Maybe you should uncomment;

  • #Option "UseDisplayDevice" "none"
  • It could solve your problem

    I tried this, but it not solve my problem.

    Check if the driver package xf86-video-modesetting is installed. Complete Xorg.0.log or at least the Warnings would be helpful, too.