Orin devkit operate Pin 40 gpio no effect

Hi:
I used the Pin 40 to test the IOs.
图片

GPIO08 in pinmux file corresponding to PBB.01
at /sys/kernel/debug/gpio " grep PBB.01
gpio-325 (PBB.01

cd /sys/class/gpio/
echo 325 >export
cd PBB.01
echo out > direction
echo 1 > value

but voltage is still low on multimeter.

On xavier platform.we use tegra19x-mb1-pinmux-p2888-0000-a04-p2822-0000-b01.cfg file set the pin mux.

I thought the IO no effect is because of the pin mux set ir incorrect
now on orin platform ,how can I set the pin mux for IOs?

Have you downloaded the pinmux spreadsheet?

Hi WayneWWW:
I had downloaded the pinmux spreadsheet.
and can generate dt file
tegra19x-jetson_agx-gpio-default.dtsi
tegra19x-jetson_agx-padvoltage-default.dtsi
tegra19x-jetson_agx-pinmux.dtsi

Hi,

Are you using Orin board or AGX Xavier? Your file names look like for AGX Xavier.

Hi WayneWWW:
I am sorry. I am using Orin board.
the file is:
Orin-jetson_agx_orin-gpio-default.dtsi
Orin-jetson_agx_orin-padvoltage-default.dtsi
Orin-jetson_agx_orin-pinmux.dtsi
and how can I use this three files.

Please check Linux_for_Tegra/bootloader/t186ref/BCT. and Linux_for_Tegra/bootloader/

Search “*gpio *”, “*padvoltage *” and “*pinmux *” and it will show you the t234 dtsi files.

Thanks WayneWWW:

Search “*gpio *”, “*padvoltage *” and “*pinmux *” and it will show you the t234 dtsi files
I have know about the way to set the default pin.

I want to know if i finished my modify. do I need both files /tegra234-mb1-bct-pinmux-p3701-0000.dtsi& tegra234-mb1-bct-gpio-p3701-0000.dtsi& tegra234-mb1-bct-padvoltage-p3701-0000-a04.dtsi in folder Linux_for_Tegra/bootloader/t186ref/BCT and Linux_for_Tegra/bootloader/

You need to replace those 3 files by the file generated by the excel spreadsheet.

Hi WayneWWW:
I edit Orin_Jetson_Series_Pinmux_Config_Template.xlsm file ,chage GPIO08 output

  1. generate three dtsi files
  2. replace those 3 files
    [egra234-mb1-bct-pinmux-p3701-0000.dtsi
    tegra234-mb1-bct-gpio-p3701-0000.dtsi
    tegra234-mb1-bct-padvoltage-p3701-0000-a04.dtsi ] Linux_for_Tegra/bootloader/t186ref/BCT and Linux_for_Tegra/bootloader/
    3…/flash.sh -r jetson-agx-orin-devkit mmcblk0p1
    reboot
    then
    cd /sys/class/gpio/
    echo 325 >export
    cd PBB.01
    echo out > direction
    echo 1 > value
    and but voltage is still low on multimeter.

Have you tried other GPIO? Is there same error or not?

Hi WayneWWW:
other IOs,
GPIO32 PP.06 gpio446
GPIO27 PN.01 gpio433
is the same result.
and I used another orin devkit .is the same result also.

Hi WayneWWW:
I replaced tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi and tegra234-mb1-bct-gpio-p3701-0000-a04.dtsi also.
Now the GPIO08 (PBB.01 ) and GPIO9 (PBB.0) can be set hige and low.
but GPIO32 PP.06 gpio446 is not ok.
I had set ablove IOs output through Orin_Jetson_Series_Pinmux_Config_Template.xlsm file and generate dtsi file .

if I use the main gpio,do i need config the clock?

Hi,

We just checked internally. There is a known bug so it is not working. Still working on the fix.

Hi
Do you have a schedule about fix this bug?

We will fix this before JP5.0 GA. But if all the fix are inside kernel, then I will share the patches.

1 Like

Hi WayneWWW:

Do you have a patch about gpio. my work is blocked on this

By GPIO32 do you mean pin 13 on the gpio header? If you recheck the carrier spec pdf, it is actually PWM01 not GPIO32