Orin Nano, custom board has no HDMI 4K image


We make our Orin NX/Nano custom board but change DP into HDMI.

I follow the topic here, and run p3509 conf for test.

We run the flash command like this:

$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh \
--external-device sda1   -c tools/kernel_flash/flash_l4t_external.xml \
-p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"   \
[flash-log_HDMI_4K.txt|attachment](upload://tvQ1LZEgHaiOnuAGN1mUYmlofYd.txt) (306.8 KB)
--showlogs --network usb0 p3509-a02+p3767-0000 internal

It can boot to prompt but HDMI can’t show 4K image(The monitor don’t even have image).
Here is the flash log and boot log (For Orin NX 16GB)
flash-log_HDMI_4K.txt (306.8 KB)
boot-log_HDMI_4K.txt (89.6 KB)

But works on my 2K monitor:
boot-log_2K_HDMI.txt (88.8 KB)

2K Monitor: DELL 23in PROFESSIONAL P2319H
4K Monitor: ASUS 31.5” 4K HDR Monitor (VP32UQ)

Thanks for help~

Do you have Orin Nano + Xavier NX devkit that can validate your monitors?


I don’t have Xavier-NX devkit on my hand, so I can’t reproduce that.

But, I found that with Orin Nano 4GB on my custom board can perform the 4K monitor test!!!

Orin-Nano-boot_4K-HDMI.txt (56.1 KB)

So, is there any different with Orin Nano and Orin NX?


No there is no difference between Orin NX and Orin Nano. They are basically same SoC with different sku.

Could you share us the xrandr result on NG and OK case?

Also, it seems you are using a very old BSP, please try to upgrade it. We don’t debug on old BSP either.

Orin NX 16GB (NG)

ubuntu@ubuntu-desktop:~$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
HDMI-0 disconnected primary (normal left inverted right x axis y axis)

Orin Nano 4GB (OK)

ubuntu@ubuntu-desktop:~$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767

HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 700mm x 390mm
   3840x2160     29.97 +  25.00    23.98* 
   2560x1440     59.95  
   1920x1080     60.00    59.94    50.00    29.97    25.00    23.98  
   1680x1050     59.95  
   1440x900      59.89  
   1280x1024     60.02  
   1280x960      60.00  
   1280x720      60.00    59.94    50.00  
   1024x768      60.00  
   800x600       60.32  
   720x576       50.00  
   720x480       59.94  
   640x480       59.94    59.93

I using the r35.3.1 of L4T, I don’t think it’s “outdated”.


Orin NX directly showed monitor not connected. Does this thing every show “connected” on your side?

As I already said, we don’t debug on old release.



I have tried r36.2 but it can’t even generate image.
Then I tried r35.4.1, with below tweak:

And it works, I merge this patch to r35.3.1 also works on Orin NX 16GB.
But the UEFI remains black, looks like I gonna rebuild UEFI or put the binary in r35.4.1 to it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.