Orin System Image Restore failure

Hi, I’m trying to flash a backup image to my Orin AGX dev kit but it stuck at the below step


I have tried with different dev kit units and also backed up from different systems (raw + system with our own software) and they are all the same. Idk what’s the reason. Here are the steps I do backup and restore.

Worth to note, that if I use the same method to flash a raw image (BSP + rootfs downloaded from the official website), it can work. But even if I didn’t change anything, just back up that newly installed system. Then I reflash the system, I’ll get stuck too.

It will get stuck forever unless i force exit. after force exit, if i reboot the orin again, the system will be gone and it won’t boot up. then i have to reflash the original raw system again.

Here’s the step of my backup and restore

Backup

cd /path/to/R34.1.1/Linux_for_Tegra
sudo ./flash.sh -r -k APP -G clone.img jetson-agx-orin-devkit mmcblk0p1 

Restore

cd /path/to/R34.1.1/Linux_for_Tegra
sudo cp bootloader/system.img bootloader/system.img.backup
sudo cp clone.img bootloader/system.img
sudo ./flash.sh -r jetson-agx-orin-devkit mmcblk0p1 

However, if I copy the system.img.backup back to system.img and reflash, it works again.

Here is the sample cloned image. clone.img - Google Drive This is just the raw image installed, didn’t install any extra stuff.

When you create the “clone.img” it will also create “clone.img.raw”. What is the exact byte size from “ls -l clone.img.raw”?

-rw-r--r-- 1 root root 62224596992 Jul 27 03:57 clone.img.raw

Do i need to also copy this raw into bootloader folder?

The size is valid. Either raw (the “.raw” file) or sparse (the one without “.raw”) works for flash if copied to system.img. The raw file is ignored if its name is not “system.img”, and it won’t matter which one you use. The sparse file is smaller and thus faster to flash. I just wanted to find out if the partition size was valid, and it is. Being stuck is for some other reason.

In case it is a sparse-to-raw conversion issue you could try copying the “.raw” file to “system.img” and try with that, but I doubt it will help. If it does help, then you found a bug in sparse-to-raw conversion (which I’ve not seen stop a flash before…flash should not care if what it flashes is valid versus garbage).

Is this a VM, or is it an actual Ubuntu 18.04 or 20.04 PC? Ubuntu 18.04 is recommended, but I think 20.04 works with JetPack/SDK Manager 5.x.

it is a ubuntu 18.04. Not VM. I’ll try the raw way today.

Still not working

Is the clone from the same release which is being used to flash it? They should match, but I would think if this fails, then it would still flash and simply not boot correctly, so I doubt this is the problem (worth checking though).

Yes, it is. i specifially installed from that version and then directly backed up the image. The version must match.

New release would be ready soon. Please check it again with new release later.

Do you have an ETA for this new version? my project depends on this feature urgently. want to know if the we can make it by the time.

Should be this week.

Sounds good, thanks