OSS and NV packages install error

Hardware Platform: DRIVE AGX Xavier™ Developer Kit
Software Version: DRIVE Software 9
Host Machine Version: Ubuntu 16.04 LTS
SDK Manager Version: 1.1.0.6343

I am having issues re-installing Drive software 9.0. During the OSS and NV install step, I get the following errors in the logs:

  • 08:46:41 INFO : OSS and NV packages : Verifying archive integrity… All good.
  • 08:46:42 INFO : OSS and NV packages : Uncompressing drive-t186ref-linux-5.1.0.2-15191604…
  • 08:46:42 INFO : OSS and NV packages : Installing drive-t186ref-linux tools (root filesystem, compilers)
  • 08:46:42 INFO : OSS and NV packages :
  • 08:46:42 INFO : OSS and NV packages :
  • 08:46:42 INFO : OSS and NV packages : Some packaging utilities are essential for proper installation of SDK/PDK.
  • 08:46:42 INFO : OSS and NV packages : Detecting necessary packages on your system…
  • 08:46:42 INFO : OSS and NV packages :
  • 08:46:42 INFO : OSS and NV packages : Package dpkg-dev is already installed, Setting it to manually installed
  • 08:46:42 INFO : OSS and NV packages : dpkg-dev was already set to manually installed.
  • 08:46:42 INFO : OSS and NV packages :
  • 08:46:42 INFO : OSS and NV packages : Some host system services are essential for cross development.
  • 08:46:42 INFO : OSS and NV packages : Detecting necessary services on your system…
  • 08:46:42 INFO : OSS and NV packages :
  • 08:46:42 INFO : OSS and NV packages : Non interactive : Installing package libbz2-1.0:i386
  • 08:46:42 INFO : OSS and NV packages : Reading package lists…
  • 08:46:42 INFO : OSS and NV packages : Building dependency tree…
  • 08:46:42 INFO : OSS and NV packages : Reading state information…
  • 08:46:42 ERROR : OSS and NV packages : E: Unable to locate package libbz2-1.0:i386
  • 08:46:42 INFO : OSS and NV packages : E: Couldn’t find any package by glob ‘libbz2-1.0’
  • 08:46:42 INFO : OSS and NV packages : E: Couldn’t find any package by regex ‘libbz2-1.0’
  • 08:46:43 INFO : OSS and NV packages :
  • 08:46:43 INFO : OSS and NV packages : ERROR: libbz2-1.0:i386 failed to install
  • 08:46:43 INFO : OSS and NV packages : Non interactive mode on : Triggering exit
  • 08:46:43 INFO : OSS and NV packages : Exiting.
  • 08:46:43 ERROR : OSS and NV packages : ERROR: Installation failed.
  • 08:46:43 ERROR : OSS and NV packages : [exec_command]: /bin/bash -c /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11 | tee -a /home//.nvsdkm/logs/DRIVE_Software_9.0_Linux_hyperion/NV_OSS_AND_NV_PACKAGES_SDK_COMP.log; exit {PIPESTATUS[{#PIPESTATUS[@]}-2]}; [error]: exit status 1
  • 08:46:43 INFO : OSS and NV packages : [ Package Install Finished with Error ]
  • 08:46:43 INFO : OSS and NV packages : [ 8.00 KB used. Disk Avail: 74.98 GB ]
  • 08:46:43 INFO : OSS and NV packages : [ NV_OSS_AND_NV_PACKAGES_SDK_COMP Install took 2s ]
  • 08:46:43 ERROR : OSS and NV packages : [error]: execution command /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11 returns 1
  • 08:46:43 INFO : OSS and NV packages :
  • 08:46:43 ERROR : OSS and NV packages : command terminated with error
  • 08:46:43 ERROR : OSS and NV packages : Install ‘OSS and NV packages’ failure, command < using adapter to install NV_OSS_AND_NV_PACKAGES_SDK_COMP@DDPX to /home//nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_DDPX > terminated with error.

I was able to do this install months ago, but now it is failing. When I manually try to install libbz2-1.0:i386 using apt-get, I get an error saying that it cannot locate that package. I already have libbz2-1.0 installed for my host architecture (amd64). Any ideas how I can fix this?

Thanks

Hello @anil.dhurjaty,
can you please compress and attach the sdk manager logs to better understanding of the error?
they are located here: ~/.nvsdkm/

also, please consider installing the current latest sdk version Drive Software 10.

Thanks for the reply. Here’s the compressed log folder

I can’t install Drive Software version 10 because my host computer is Ubuntu 16.04.DRIVE_Software_9.0_Linux_hyperion.tar.gz.txt (16.5 KB)
Note, I had to change the extension of the .tar.gz file to txt in order to upload it. Just remove the .txt extension and you should be able to decompress it.

Hi @anil.dhurjaty,
you have compressed and attached only the log folder in the ~/.sdkm folder.
can you please compress the whole ~/.sdkm folder and attach it?
(notice that zip files can be attached also)

thanks

Hi @anil.dhurjaty,
also, can you please verify that the comamnd ‘sudo apt update’ passes with no errors?

Sorry about that. Here’s the entire zip archive: nvsdkm.zip.txt (1.7 MB)

Still can’t upload a zip file - I get the following message: Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif, log, doc, docx, txt, cpp, c, rtf).

I added a .txt extension again to circumvent this.

Here’s the output from apt-get update:
Get:1 file:/var/cuda-repo-10-0-local-10.0.166-410.62 InRelease
Ign:1 file:/var/cuda-repo-10-0-local-10.0.166-410.62 InRelease
Get:2 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 InRelease
Ign:2 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 InRelease
Get:3 file:/var/cuda-repo-10-0-local-10.0.326-410.108 InRelease
Ign:3 file:/var/cuda-repo-10-0-local-10.0.326-410.108 InRelease
Get:4 file:/var/nv-tensorrt-repo-cuda9.0-rc-trt4.0.0.3-20180329 InRelease
Ign:4 file:/var/nv-tensorrt-repo-cuda9.0-rc-trt4.0.0.3-20180329 InRelease
Get:5 file:/var/cuda-repo-10-0-local-10.0.166-410.62 Release [574 B]
Get:6 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 Release [574 B]
Get:7 file:/var/cuda-repo-10-0-local-10.0.326-410.108 Release [574 B]
Get:8 file:/var/nv-tensorrt-repo-cuda9.0-rc-trt4.0.0.3-20180329 Release [574 B]
Get:5 file:/var/cuda-repo-10-0-local-10.0.166-410.62 Release [574 B]
Get:6 file:/var/cuda-repo-10-0-local-10.0.166-cross-aarch64 Release [574 B]
Get:7 file:/var/cuda-repo-10-0-local-10.0.326-410.108 Release [574 B]
Get:8 file:/var/nv-tensorrt-repo-cuda9.0-rc-trt4.0.0.3-20180329 Release [574 B]
Ign:10 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 InRelease
Hit:11 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1604/x86_64 Release
Hit:13 http://dl.google.com/linux/chrome/deb stable InRelease
Hit:16 http://packages.microsoft.com/repos/vscode stable InRelease
Hit:17 http://packages.ros.org/ros/ubuntu xenial InRelease
Hit:19 http://ppa.launchpad.net/webupd8team/atom/ubuntu xenial InRelease
Hit:20 http://archive.ubuntu.com/ubuntu xenial InRelease
Reading package lists… Done

Hi @anil.dhurjaty,

it seems like a linux related issue.
please try executing the following command:
sudo dpkg --add-architecture i386
sudo apt update
and then manually install the package, if this succeeds then try installing normally through SDK Manager.

was Drive Software 9.0 previously installed on the same computer that you are trying to reinstall?
did you uninstall Drive Software 9.0 before reinstalling it?

thanks

Same issue:

E: Unable to locate package libbz2-1.0:i386
E: Couldn’t find any package by glob ‘libbz2-1.0’
E: Couldn’t find any package by regex ‘libbz2-1.0’

Yes, I uninstalled through the SDK manager and reinstalled on the host machine

Hi @anil.dhurjaty,

it seems there is something wrong in your host computer environment. have you tried installing on a different computer?

also, please try instead to download the deb file directly from here: http://security.ubuntu.com/ubuntu/pool/main/b/bzip2/libbz2-1.0_1.0.6-8ubuntu0.2_i386.deb
and install it manually by executing:
sudo apt install ./libbz2-1.0_1.0.6-8ubuntu0.2_i386.deb
and see if it solves the problem.

Thanks for sharing the link. I was able to manually install the package, but when I re-run the installation I get a different error for the same thing (OSS and NV packages):

  • 11:22:18 INFO : OSS and NV packages : verifying checksum of /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run
  • 11:22:18 INFO : OSS and NV packages : verifying checksum of /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-initramfs.run
  • 11:22:18 INFO : OSS and NV packages : verifying checksum of /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-drive-platform-rootfs.run
  • 11:22:18 INFO : OSS and NV packages : Found file /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-initramfs.run with correct checksum, skip downloading.
  • 11:22:18 INFO : OSS and NV packages : verifying checksum of /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-nv-minimal-sdk.run
  • 11:22:19 INFO : OSS and NV packages : Found file /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run with correct checksum, skip downloading.
  • 11:22:19 INFO : OSS and NV packages : verifying checksum of /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-src.run
  • 11:22:21 INFO : OSS and NV packages : Found file /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-nv-minimal-sdk.run with correct checksum, skip downloading.
  • 11:22:29 INFO : OSS and NV packages : Found file /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-drive-platform-rootfs.run with correct checksum, skip downloading.
  • 11:22:58 INFO : OSS and NV packages : Found file /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-src.run with correct checksum, skip downloading.
  • 11:22:58 INFO : OSS and NV packages : Download ‘OSS and NV packages’ success
  • 11:23:10 INFO : OSS and NV packages : Start to install ‘OSS and NV packages’
  • 11:23:10 DEBUG : OSS and NV packages : using adapter to install NV_OSS_AND_NV_PACKAGES_SDK_COMP@DDPX to /home//nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_DDPX
  • 11:23:10 INFO : OSS and NV packages : [ Disk Avail:77.99 GB ]
  • 11:23:10 INFO : OSS and NV packages : Using GenericInstaller to Install NV_OSS_AND_NV_PACKAGES_SDK_COMP
  • 11:23:10 INFO : OSS and NV packages : NV_OSS_AND_NV_PACKAGES_SDK_COMP include 5 package
  • 11:23:10 INFO : OSS and NV packages : change working directory to /home//nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_DDPX/DriveSDK
  • 11:23:10 INFO : OSS and NV packages : [ Package Install Started ]
  • 11:23:10 INFO : OSS and NV packages : runfile installer start to install NV_OSS_AND_NV_PACKAGES_SDK_COMP
  • 11:23:10 INFO : OSS and NV packages : change working directory to /home//nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_DDPX/DriveSDK
  • 11:23:10 INFO : OSS and NV packages : .install/ folder from previously installed component exists and is being removed
  • 11:23:10 INFO : OSS and NV packages : exec_command: /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11
  • 11:23:10 INFO : OSS and NV packages : Verifying archive integrity… All good.
  • 11:23:11 INFO : OSS and NV packages : Uncompressing drive-t186ref-linux-5.1.0.2-15191604…
  • 11:23:11 INFO : OSS and NV packages : Installing drive-t186ref-linux tools (root filesystem, compilers)
  • 11:23:11 INFO : OSS and NV packages :
  • 11:23:11 INFO : OSS and NV packages :
  • 11:23:11 INFO : OSS and NV packages : Some packaging utilities are essential for proper installation of SDK/PDK.
  • 11:23:11 INFO : OSS and NV packages : Detecting necessary packages on your system…
  • 11:23:11 INFO : OSS and NV packages :
  • 11:23:11 INFO : OSS and NV packages : Package dpkg-dev is already installed, Setting it to manually installed
  • 11:23:11 INFO : OSS and NV packages : dpkg-dev was already set to manually installed.
  • 11:23:11 INFO : OSS and NV packages :
  • 11:23:11 INFO : OSS and NV packages : Some host system services are essential for cross development.
  • 11:23:11 INFO : OSS and NV packages : Detecting necessary services on your system…
  • 11:23:11 INFO : OSS and NV packages :
  • 11:23:11 INFO : OSS and NV packages : Package libbz2-1.0:i386 is already installed, Setting it to manually installed
  • 11:23:11 INFO : OSS and NV packages : libbz2-1.0:i386 was already set to manually installed.
  • 11:23:12 ERROR : OSS and NV packages : ERROR: Installation failed.
  • 11:23:12 ERROR : OSS and NV packages : [exec_command]: /bin/bash -c /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11 | tee -a /home//.nvsdkm/logs/DRIVE_Software_9.0_Linux_hyperion/NV_OSS_AND_NV_PACKAGES_SDK_COMP.log; exit {PIPESTATUS[{#PIPESTATUS[@]}-2]}; [error]: exit status 1
  • 11:23:12 INFO : OSS and NV packages : [ Package Install Finished with Error ]
  • 11:23:12 INFO : OSS and NV packages : [ 134.73 MB used. Disk Avail: 77.85 GB ]
  • 11:23:12 INFO : OSS and NV packages : [ NV_OSS_AND_NV_PACKAGES_SDK_COMP Install took 2s ]
  • 11:23:12 ERROR : OSS and NV packages : [error]: execution command /home//Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11 returns 1
  • 11:23:12 INFO : OSS and NV packages :
  • 11:23:12 ERROR : OSS and NV packages : command terminated with error
  • 11:23:12 ERROR : OSS and NV packages : Install ‘OSS and NV packages’ failure, command < using adapter to install NV_OSS_AND_NV_PACKAGES_SDK_COMP@DDPX to /home//nvidia/nvidia_sdk/DRIVE_Software_9.0_Linux_hyperion_DDPX > terminated with error.

Seems I can’t win.

I’ve attached the logs - same deal with removing the .txt extension. nvsdkm.zip.txt (2.2 MB)

Haven’t tried a new computer. One is not available to me at this time.

Hi @anil.dhurjaty,

can you please post the output if you execute manually the following:
chmod 0755 /home/flir/Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11
/home/flir/Downloads/nvidia/sdkm_downloads/drive-t186ref-linux-5.1.0.2-15191604-oss-minimal-sdk.run --nox11

Hi @shayNV

I get the license info and then:

Do you accept the terms of this license? yes/no? yes
Verifying archive integrity… All good.
Uncompressing drive-t186ref-linux-5.1.0.2-15191604…
Installing drive-t186ref-linux tools (root filesystem, compilers)

Some packaging utilities are essential for proper installation of SDK/PDK.
Detecting necessary packages on your system…

Package dpkg-dev is already installed, Setting it to manually installed
dpkg-dev was already set to manually installed.

Some host system services are essential for cross development.
Detecting necessary services on your system…

Package libbz2-1.0:i386 is already installed, Setting it to manually installed
libbz2-1.0:i386 was already set to manually installed.
ERROR: Installation failed.

Hi @anil.dhurjaty,
we are trying to reproduce your issue on our side.

at the meantime, please try the following:

  1. uninstall DS 9 using SDK Manager
  2. execute the following
    dpkg --get-selections | awk '/i386/{print $1}' | xargs sudo apt-get remove --purge -y
    sudo dpkg --remove-architecture i386
    sudo apt update
  3. make sure there are no errors on the update command (otherwise fix those errors using “Software & Updates” ubuntu form)
  4. try reinstalling Drive Software 9 using SDK Manager.

if that does not work, the only recommendation, for now, would be to try using another host computer.

Hi @shayNV

Sorry for the delay. Same errors. I’ll have to work with my team to get a new computer or update my host OS

Thanks so much for your help through this

Hi @anil.dhurjaty,

We have not been able to repro the issue locally. Any update or ETA on the new computer?

Thanks.

We will suspend this topic for now. Let us resume the discussion when you get a chance to try on the new system if you still face the issue.