Planetside 2 Physx not working? GeForce GTX 675MX

Well supposely my video card has a physx but in planetside 2 i cant even run physx, i tried installing physx but it said that my graphic software is not compatible? solution?

Hi,

Sorry I missed this post earlier. Did you sort out the problem? Planetside2 is supposed to provide the proper patch, but it’s possible that some other product on your computer has caused confusion in the installer or PhysX runtime.

“i tried installing physx but it said that my graphic software is not compatible? solution?”

Do you have other graphics cards installed besides the GTX 675MX? Is this an Optimus system with Intel integrated graphics? If so, there’s probably a bug somewhere in the logic that detects the PhysX GPU.
–Mike

I have an optimus system with an Intel HD integrated graphics

OK, I’ll bring this to the attention of an Optimus expert.
–Mike

Have you set the Graphics Processor setting in the NVIDIA Control Panel to point to the GTX?


https://devsupport.ageia.com/FileManagement/Download/0b505eea38cd4939a65df9ff95816e9b

https://devsupport.ageia.com/FileManagement/Download/a200fbc95c744755a070f4c32dba754b

Some features in this forum don’t seem to work properly. Please copy-past the links above, they are images of a control panel configuration.

Yeap all my setting were always like that exactly the same with the picture u gave me.

Did you ever run a 3rd-party uninstaller to ‘clean up’ your computer? Some of them have been shown to break the PhysX installation because they don’t completely clean up the old installation.

i do not think so i only tried to instal physx and update nvidia drivers so far iguess but nothing seems to work because the first time i got this laptop i let my windows update instal planetside 2 and physx not working without me changing anything on the laptop

Which version of the GPU driver are you running? You can find the information on the NVIDIA Control Panel, click the link that says “System Information”. You need to run a GPU driver that is no older than the Planetside 2 release.

Also, go here to download the most recent driver: http://www.nvidia.com/Download/index.aspx?lang=en-us. Be sure to select “GeForce 600M Series”.

my gpu driver is 326.01

and ihave windows 8.1

This is a silly question on my part, but are you running Planetside as a ‘desktop’ application? I haven’t heard of a Modern-style version of Planetside, just thought I’d check.

I suspect the problem lies in the combination of 326.01 driver, which is for the Windows 8.1 ‘preview’, and the released PhysX code that comes with Planetside 2. We’ll try to reproduce this. I don’t have an Optimus machine handy, I’ll have to ask around. Meanwhile, it seems that the recommended driver for your setup is the 326.19 beta: http://www.nvidia.com/object/notebook-win8-win7-326.19-beta-driver.html

Have you tried to run any other PhysX-enabled content? Do you have the PhysX Visual Indicator turned on? Did you right-click on the program launcher and select “Run On High Performance NVIDIA GPU?”
Thanks,
Mike

Hey sorry have not been checking for long and i will tell u after i download it and test it

i have tested it and stil does not work