Poor desktop framerate under X11 with rotated 4K display over DP

I recently upgraded from a 1070Ti to a 2080Ti, and with the new graphics card came nearly unusable performance on my primary portrait 4k display. When I first start X it is fine, but within 10 seconds it will drop to 30 fps, as confirmed by testufo.com, and with several frames of latency. If I screen record my desktop and play it back on another display it is at the correct refresh rate. This only happens if the monitor is

  1. at its native 4K resolution. Reducing it to a non-native 1080p fixes it
  2. Rotated in any way. Setting it to No rotation also fixes it
  3. Using DisplayPort. Using HDMI makes the monitor limited to 30Hz, but fixes the latency
  4. Using X11. Using wayland makes it perform correctly, but wayland is still unusable in other ways so that is not a real option.

I have tried without success:

  1. Forcing G-SYNC on and off
  2. Various different display port cables
  3. Both “60Hz” display modes – Sometimes nvidia-settings will show a second 60Hz display mode that is actually 59.97
  4. Running my other high-refresh rate display at 60Hz instead of it’s native 165
  5. Every combination of Force (Full|) Composition Pipeline settings
  6. Only attaching the affected 4k display
  7. Changing the XVideo sync display
  8. Using other DisplayPort outputs on my GPU
  9. Using OpenBox

Arch Linux / 6.1.12-arch1-1/ 525.89.02

nvidia-bug-report.log.gz (549.1 KB)

Does setting “prefer maximum performance” in nvidia-settings change anything?

Unfortunately, it does not.

The attached nvidia-bug-report.log is missing any xorg logs and nvidia-smi is showing only an xorg process with 70MB. Which DE are you using?

I am just using i3, not a full DE. I have also tried this with openbox. In that run the only application running was one urxvt to take the bug report with. Attached is the xorg log from what I believe to be the same run that took the bug report in the OP.
Xorg.0.log.gz (65.7 KB)