Power supply considerations for Jetson Nano Developer Kit

Interessting. The output directly after the powersupply shows 5.06 the device, the command displays 4.520. Its a 10cm USB Cable. So where is the voltage drop/loss? What can other powersupplys do better? The output directly after the powersupply actually matches the requirement.

Second question, any experience with the 5V/4A barrel powersupply of waveshare? (claimed to be for the jetson nano).

I guess any power supply is good as long as it can deliver 4A without losing too much voltage at its output and provides 5.25V (as far as I know, commercial power supplies intended to be used for Jetson Nano never provide more than 5.20-5.25V at their output for safety reasons). 5.1V may be good too if you do not plan to go far beyond 10W but for me with power consumption of almost 20W this turned out to be not enough, I had to increase input voltage: my experience with “barrel” power supply is that I needed 5.35V at the power supply output to get 5.22V-5.25V at in_voltage0_input without CPU/GPU load and without USB devices connected and to keep it above 4.75V under heavy load (in my case 18W or almost 4A).

My experience with MicroUSB power - it is only good for 5W mode even with short cable and high quality power supply capable of sustaining 5.1V under load at its output.

Another option is to power directly via the 40-pin header, but this will bypass all protection (so voltage drop under load will be less) and may damage Jetson Nano if power supply is not very good, or voltage drop may become even worse if using cheap thin wires or bad connectors.

1 Like

Bought the Waveshare 5V/4A Barrel Supply. It does work like a charm. Stable voltage of >4.9V during high system load.

However I do get this error on high system load (9-10W):
[ 1276.395026] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[ 1276.395037] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[ 1276.405370] pcieport 0000:00:01.0: device [10de:0fae] error status/mask=00000001/00002000
[ 1276.413848] pcieport 0000:00:01.0: [ 0] Receiver Error (First)

Did you measure output voltage of the power supply or voltage input of Jetson Nano by running sudo cat /sys/bus/i2c/drivers/ina3221x/6-0040/iio:device0/in_voltage0_input? Because if your power supply voltage actually drops to 4.9V there is a good change that the input voltage will drop below 4.75V. With high quality power supply capable of delivering 2A, input voltage should remain above 4.75V while Jetson Nano consumes 10W. If you did measure the input voltage by running the command and it is above 4.75V then most likely your issue is not caused by low voltage.

Therefore the error you are seeing may not be caused by low voltage. I think I saw similar errors in the past on my Jetson Nano, even though they are marked as “corrected” and should be harmless, they annoyed me. In my case they were caused by PCIEASPM_POWERSAVE being enabled. For some reason these errors can happen even if nothing is installed in PCI-E M.2 slot, and they continued to happen after adding a WiFi/Bluetooth card. I made the following changes before building the kernel:

--- a/kernel/kernel-4.9/arch/arm64/configs/tegra_defconfig
+++ b/kernel/kernel-4.9/arch/arm64/configs/tegra_defconfig
@@ -47,7 +47,8 @@ CONFIG_PARTITION_ADVANCED=y
 CONFIG_ARCH_TEGRA=y
 CONFIG_PCI=y
 CONFIG_PCIEPORTBUS=y
-CONFIG_PCIEASPM_POWERSAVE=y
+CONFIG_PCIEASPM_POWERSAVE=n
+CONFIG_PCIEASPM_PERFORMANCE=y
 CONFIG_PCI_STUB=m
 CONFIG_PCI_IOV=y
 CONFIG_PCIE_TEGRA=y

I did not see these errors after this.

Disabling PCIe ASPM is also possible without recompiling the kernel by running:

echo performance | sudo tee /sys/module/pcie_aspm/parameters/policy

If it helps, keep in mind that this command have no permanent effect, and after reboot you need to run it again. Recompiling the kernel with the patch above will have permanent effect.

I was first confused because the default power configuration seems to have changed between revisions A01 and B01. Most instructions are for A01, which doesn’t include the J48 jumper out of the box. However, on my B01 board the jumper was already attached when I bought the device as new.

On the B01 revision, the jumper J48 must be removed by default in order to use micro USB power. I didn’t see this being explicitly mentioned here before.

Hi! I downloaded twice to sd card. but screen stops at the full screen nvidia logo. i m using 2gb, usb C 5v 2A

what can be the problem? thanks

Read this thread, 2A current is very likely too low

now I changed 10A usb port
still only full screen logo

Maybe your SD card was not flashed correctly. I suggest to discuss this in another thread as this one here is about power supplies…

Can I power my jetson nano with phone charger? the charger is a ‘VOOC flash charger’ who got 5V/4A. Iam just worried because I don’t want to damage my jetson.

5V chargers on a 5V dev kit won’t damage a Nano (other non-Nano model dev kits require other voltages, all of which are higher than 5V). For the most part a 5V phone charger with 4A available should work well, and definitely won’t damage the unit. However, unless the regulation is sufficiently tight, you might find the unit shuts down when there is a very short spike in needed current…some cheap regulators can’t keep up with short power spikes and let the voltage drop for a tiny amount of time, and the Nano requires good quality regulation. Give it a try, and it won’t hurt on a Nano dev kit, but you also need to verify that it is stable under various loads. Chances are it will work. If not, then adding capacitance right at the connector would do the job (of course you’d have to create an adapter to go from cell charger to capacitor and then to the Nano).

@linuxdev okay thank you, I tried it and it is working fine

Hello, @dusty_nv

When I unplug the dc jack from the jetson nano devkit carrier board and immediately plug the dc jack back in, sometimes it does not boot. When the dc jack is unplugged, the power does not immediately drop to 0 volts.
Slowly drops to 0 volts over 5-10 seconds.

How can I solve this?

Thank you.

Hi, I have some info to add re using boost-buck modules to power a Nano via the barrel jack.
In a way answering my own question at Issue with powering Jetson Nano from Boost-Buck converter
and also providing evidence for “system throttled due to overcurrent” messages
As @linuxdev points out “However, unless the regulation is sufficiently tight, you might find the unit shuts down when there is a very short spike in needed current…some cheap regulators can’t keep up with short power spikes”

I finally got access to a scope and could see a couple of issues with all power supplies.
a) what happens at power-on can affect the Nano’s ability to boot at all.
b) the Nano seems to cause a lot of spikes in any unit’s abilty to keep up - this can be seen as large peak-to-peak values. When the Nano is off these go away

In the end I measured powering it directly from the Plug pack and using 4 different boost-buck or just buck modules
I have a switch on my device so there is a consideration to make

  • should the switch be AFTER the power module - which means the power module can stabilise before being sent to work
  • should the switch be BEFORE the power module which means the nano can benefit from any ‘soft start’ features incorporated

The measurements were V out of the module, at the input plug to the Nano then the internal measurements (which must be what is used for the ‘system throttled’ state)
The attached picture shows the modules. From Left to right they are

  1. DC-DC 9V/12V to 5V 4A Mini Buck Module Converter Step Down Module ID: 1343488 $5.49USD
    (unmarked) DC-DC 9V/12V to 5V 4A Mini Buck Module Converter Step Down Module Sale - Banggood Australia
  2. pololu module D24V50F5 as noted by @wuxiekeji
    I got mine from Core Electronics in Aus https://core-electronics.com.au/search/?q=d24v50f5 $36.40AUD
  3. 30W 4A DC Auto Step Up/Down Converter 5V~30V to 9V 12V 19V 24V Boost-Buck Module $4.95USD
    30W 4A DC Auto Step Up/Down Converter 5V~30V to 9V 12V 19V 24V Boost-Buck Module | eBay
  4. 30/35W DC-DC 3A Auto Buck Boost Step Up/Down Power Supply CC CV Regulator Module
    board labled - XY-SJV-4. Its from ebay but I cant find it there any more.

    Items 3 and 4 will not power the Nano without persuasion. I purchased item 3, the 4A version because I expected to stress the unit a bit with GPU stuff.
    As it stands today the base program (with some video analysis), when powered from desktop power supply only draws <1.3A for the whole setup including Arduino, all the servos, serial interface modules and so on.
    So, so far we are not current constrained.
    Item 3 has a shocking power on profile - rising to about 7.4V and taking 2 whole seconds to settle. No wonder the Nano has a fit and will not boot at all.
    If you adopt the ‘switch before’ idea then it will have settled before powering the Nano - which it does but it still gets ‘Throttled messages’

Item 4 has an issue where it cant regulate quickly enough - it varies 4.08V to 5.68V about every 5ms

Item 2 suffers from under voltage to start with. This module has a constant 5V output its specs are 5V ± 4% so 4.8 to 5.2V
mine was delivering 4.978V on the scope it is OK, barely, rise time 8ms really good
but with the Nano’s range 4.75 to 5.25 (from the data sheet) it is just sailing too close to the lower limit for me

                 min   max   mean   meter reads internal
unloaded         4.59  5.08  5.00   4.993
turning Nano on  4.68  5.02  4.91   4.965                       Throttled
run main prog    4.68  5.04  4.88   4.955       4.672 to 4.712  Throttled!

Frankly I dont think ANY 5.0V module can work properly with the Nano. Even the plug pack starts at 5.11V

Item 1. This is the current winner. Its specs are 5.3V ± 1% so 5.247 to 5.353
I was worried about it being too high a voltage but looking internally its fine. Strangely it is also the smallest (less than an Aussie 5cent coin) and does not get hot at all.

                         Module out  Plug_in         Internal         Internal-I(mA) scope            p2p
unloaded                    5.34     4.918           
quintescent - idle          5.318    5.255           5.120 to 5.144                  4.48-5.52 ~5.20  640mv   (includes started tasks like serial2mqtt and mosquitto)
with visual studio open     5.325    5.265           5.160 to 5.176    416 to 424    4.52-5.40 ~5.01  880mv   is a bit Throttled!
with main prog running      5.310    5.200 to 5.230  5.000 to 5.072    784 to 1000                            NOT Throttled!

it also has an excellent power on rise time of 2.5ms

My next experiment is to add a capacitor to try and hold the voltage to eliminate some of the peak-2-peak issues these little module exhibit.
Trying with the bench power supply this is seen as about 85mv vs 880mv for the babies.

related references
from "System throttled due to Over-current."
and my previous post Issue with powering Jetson Nano from Boost-Buck converter
using advice on internal measurements Nvidia Jetson Nano / Xavier power monitoring | by ihwoo | Medium
somewhere in there it resolves to :-

sudo -s
cd /sys/bus/i2c/drivers/ina3221x 
cd 6-0040
cd iio:device0
cat in_voltage0_input

Thanks - I hope this helps others
JC

1 Like

One possible cause of power problems (that I don’t think has been covered in this thread) is the cable from the power supply to the device.

The voltage drop over a thin cable can be enough to make the Nano power down (or halt, or whatever it does when the green light goes out).

I have often had this problem with USB-A to micro-USB cables, and there are many thin, flimsy USB-A to 5.5mm barrel plug cables.

A power supply that claims to provide 2A or higher SHOULD have a sufficiently heavy cable to the barrel connector… but that’s not always the case.

So - if your power supply is more than powerful enough but the Nano still stops - try upgrading the power cable! This will probably be easier to do if you move to the 5.5mm barrel connector at the same time.

Cheers
Sean

1 Like

Hello,
I have just purchased a Jetson Nano 2 GB developer kit fom Arrow Electronics and it comes with an USB-C connector for power instead of the barrel one. It says to power it with 5V 3A and although I have tried using a mobile power supply according to these terms, I suspect it is not appropriate since I only get a white screen with Nvidia logo on startup. I have followed the steps on the web guide and it only says about the micro-USB or barrel options, suggesting a 5V 2.5 A supply.
Is there an official or recommended power supply for my version of Jetson Nano?

Thank you very much
Rafael Caballos

1 Like

This is very outdated content. Compared to SO (Stack Overflow) this is really really low quality. I expected much more from NVIDIA.
I am the same situation as Rafael Caballos and there is no easy FAQ here for ‘new models?’ of jetson nano that comes with type c usb.

I bought a Switching Power Adapter 5v/3000ma described for a Raspberry Pi 4 from Amazon ~$12 USD, Nano boots up & works great. DC Output is ~5.2vdc.

Hi! (Hardware problem (?))
I’ve always used a Waveshare Power supply with 5V ~ 3A plug jack on my Jetson Nano B01. But one day, the LED no longer lights. How can I fix this??
The instructions say to always turn off the Jetson through the software before unplugging it, which I did. I don’t know if I should let it stabilize itself (?)
Any help with this Issue? Thanks.