PowerMizer always at high performance level 3 with drivers newer than 346.59

I’ve contacted Nvidia support and sent them the nvidia-bug-report, but never got any response back, so i thought I’d try the forum and see if anyone can, 1) confirm the problem exists with me, 2) maybe help identify a resolution.

The problem:
PowerMizer always at highest level 3.

My hardware setup:
I’m currently running Fedora 23 Linux, with a EGVA GTX 980 (04G-P4-2983-KR) graphics card. I’ve got the system hooked up to 3 monitors, a 27" in landscape@1920x1080, and two 24" in portrait@1080x1920 on each side of the 27" monitor.

Problem details:
I’ve used various versions of the nvidia driver, and although they functionally work, after 346.59, I have the issue that PowerMizer shows the graphics card is always at performance level 3, and hence usually running warm to hot when the system is idle. I’ve tried various versions of the nvidia driver, and this problem started happening after 346.59. Here’s a history of the drivers I’ve tried:

343.22 - no problem
346.35 - no problem
346.47 - no problem
346.59 - no problem
349.16 - problem exists
352.30 - problem exists
352.79 - problem exists
355.11 - problem exists
358.16 - problem exists
361.18 - problem exists

I noticed there is a 361.28 release now, but I haven’t tried that yet. I don’t see any mention of this issue in the release notes, so not exactly hopeful this will get resolved.

Any ideas guys?


I can’t exactly say which driver release started this issue, but I can confirm that with 361.28 (which I’m using right now) the performance level always is 3.

From what I remember, I first noticed this issue at least 4 driver releases ago.

I’ve asked this question here before – the issue, apparently, is that there’s a chance of the display server underflowing (or something like that) when re-clocking the memory with 3 or more monitors connected, so connecting 3 monitors will automatically force the GPU into its highest power state. It doesn’t need to be running in this state to drive the monitors – you can force the lowest power saver state at boot if you want, and it’ll work fine, but it’ll never reclock – but whoever wrote the driver decided reclocking wasn’t safe with that many displays hooked up.

It’s a major pain but I think it’s a won’tfix.

@dliw: thanks for confirming the issue… yeah, after posting above, i also did try the 361.28 and it also has the issue. what’s your configuration? (GPU, monitor(s), etc.)

@axfelix: I can understand if this has always been the case, but it was working as expected until 346.59. when you say “it’s a won’t fix”, is that your assumption or based on some conversation with Nvidia support/tech?

Based on a post of mine that was answered in this forum by Nvidia a few months ago. I gather it’s gotten worse lately but they don’t consider it a bug.