PowerMizer's performance level goes max to lv.2 from 4 possible on GTX 580m

Hi Nvidia guys !

I have Alienware M17xR3 laptop with GTX 580m. To use the discrete video card I use Bumblebee project. At first I thought everything was ok. With optirun `program' everything worked higher FPS compared to to intel's one, but later on I found out there was a problem. The performance wasn't as I was expecting from this card, it was much worse. I started to search for the problem and finally I found it. The video card has 4 possible performance levels, but I could go max to 2.

I never managed to make the card to go more than level two. I googled the problem and I found a lot of solutions, which unluckily didn't work for me. Some were supposed to disable powermizer but they didn't. Others were supposed to lock the performance at certain level, but for me it locked only for lv.1 and and 2. Third ones made the card to go all out, like `optirun nvidia-settings -q all', but it still didn't go beyond level 2. What ever I tried problem couldn't be solved.

I'm sorry if I'm too descriptive, but I don't remember all things I did and tried. I hope this is not a problem for you, but I'm sure I tried everything I managed to find in your ex-forum.

After 2 weeks of research I finally found something that brought hope. It was on your previous forum for linux support: [url]http://www.nvnews.net/vbulletin/showthread.php?t=177688[/url]. In this thread there is link to other thread where danix(from nvidia) says that the problem is the communication between the kernel ACPI and the BIOS. He gave another link where this problem can be worked around if we just exchange places of two functions in the DSDT table. I followed the instructions, but the result wasn't as I hoped. The problem remained and I managed to introduce a new one(I couldn't change brightness). Now I don't know what to do. The only thing that comes to my mind is to update my bios:

My current one is:

BIOS Information
Vendor: Alienware
Version: A09
Release Date: 10/13/2011
Address: 0xE0000
Runtime Size: 128 kB
ROM Size: 2560 kB
Characteristics:
PCI is supported
BIOS is upgradeable
BIOS shadowing is allowed
Boot from CD is supported
Selectable boot is supported
EDD is supported
Japanese floppy for NEC 9800 1.2 MB is supported (int 13h)
Japanese floppy for Toshiba 1.2 MB is supported (int 13h)
5.25"/360 kB floppy services are supported (int 13h)
5.25"/1.2 MB floppy services are supported (int 13h)
3.5"/720 kB floppy services are supported (int 13h)
3.5"/2.88 MB floppy services are supported (int 13h)
8042 keyboard services are supported (int 9h)
CGA/mono video services are supported (int 10h)
ACPI is supported
USB legacy is supported
BIOS boot specification is supported
Targeted content distribution is supported
UEFI is supported
Firmware Revision: 1.1

The newest version is A12. In it’s fix description I can’t see anything that could fix the problem, but for the previous version A10(there is no A11) I see:
Change eDP ACPI ID to support updated NV-GTX2 adjust brightness.
I’m not sure if this is related to the blank screen problem as described in the thread for DSDT modification, but it sounds close.
I decided to wait with the BIOS upgrade after I receive some information and suggestions from you.

I’m attaching a bug report with this post. This report was generated like this without exiting the game:
optirun xterm
On xterm window:
/opt/amnesia/Launcher.bin64
And starting the game.

P.S. I forgot to mention that I’m using the latest driver 310.14 for ubuntu x-swat repository.
P.S2. Sorry but for some reason I can’t find the button attach so I uploaded the file on my google drive. Here is the link: https://docs.google.com/open?id=0B4brJaD_AYiBLTBzSHJDY0l0S0U

As I can’t edit my previous post I’m creating this one to give more info about my problem.

Just now I upgraded my bios from A09 to A12. As much as I hoped my problem would be fixed with this version it wasn’t. The problem is still present. I tested with drivers version 310.19.

I’m left without anymore ideas. I hope that soon I’ll get official response about this.

I’m attaching and screenshot of PowerMizer a second after executing ‘optirun nvidia-settings -c :8 -q all’.

Hi ytsolov,

Thanks for reporting this; I’m going to try to see if we have a similar AlienWare model that we could use to observe this issue.

Thanks,

  • Pierre-Loup

I’m basically seeing the same problem - I have a Toshiba Qosmio 870-11R laptop (specification sheet here:
http://uk.computers.toshiba-europe.com/innovation/product/Qosmio-X870-11R/1126405/toshibaShop/false/
with a GeForce 670M. This runs under Fedora 17 with the 3.6.7 64bit kernel. I’ve now installed the 310.19 driver.

PowerMizer offers 4 performance levels, but the performance level reaches never above 1, 2 and 3 remain unused regardless of the rendering load.

The output of nvidia-bug-report.sh is here http://users.jyu.fi/~trenk/nvidia-bug-report.log.gz in case this is of any use.

Unfortunately I can’t make too much sense out of what ytsolov says about DSDT tables, I’m not a hardware specialist and couldn’t try that.

Hi Plagman,

Thanks for your previous reply, but two weeks passed and I would like to know whether there is some progress. Did you find a laptop like mine or like Thorsten’s one. If you did, did you manage to reproduce the problem? If you couldn’t I’ll be glad to help you in whatever way you need, so that we can resolve this problem.

As a side note I want to tell you what I tried while waiting for activity in this thread. While compiling my DSDT file I have some error, warning and remarks. Last time that I edited the DSDT file I didn’t fix the problems and I just exchanged the two functions. This time I tried fixing the problems with and without exchanging the functions, but I got nothing. Still doesn’t work.

Other thing that I would like to ask you (if you know of course) is whether the problem I’m having is the same one as the one that is described in the thread in your old forum that I gave link to in the first post. I’m asking so that I could know whether to spent more time on my DSDT or just forget about it and wait for you to fix it.

Thanks.

EDIT: I opened a bug at launchpad for this problem: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/1096155

I’m updating with a little bit more info my problem.

After installing nvidia-313 from xorg-edgers ppa I got a new problem that my BIOS didn’t everytime recognize my discrete NVIDIA card. I don’t think it’s caused by the driver, but it’s just a coincidence. So anyway I started researching it and I came accross one of the options in my BIOS in “Advanced” tab “Primary Display”. It had two options “SG”(Switchable Graphics) and PEG(Peripheral Graphics). On SG I have Optimus enabled and on PEG I have only my discrete card enabled. On SG I was suffering the problem that my NVIDIA card isn’t found each time, while on PEG it was found each time. So after setting Primary Display to PEG I installed again nvidia-313 package and tried PowerMizer. This time it worked. I tested with “Amnesia: The Dark Descend” and the game wasn’t lagging anymore. After checking PowerMizer I confirmed that it was moving successfully between all 4 performance levels. There was something that I didn’t like about it though. PowerMizer was preffering the loweest and highest performance levels. For example if I’m on the lowwest and started changing desktops, the desktop animations lag a little but PowerMizer statys in lowwest level. When doing the same when in highes level it doesn’t go down.

So it looks like when Optimus is enabled PowerMizer isn’t working correctly, but when it’s disabled PowerMizer can use all performance levels.

I hope this helps you to easier localize the problem.

Hi.

I’m suffering from possibly the same issue/bug. Made a new topic here: https://devtalk.nvidia.com/default/topic/528357/linux/powermizer-bug-adaptive-performance-level-stuck-on-highest-gtx670m-linux-mint-14-driver-304-310-/

Made new topic since I’m not sure this is the same issue.