Premiere Pro CD5.5 Crashing on launch in Lion with Geforce GTX 285

I am having issues running Premiere Pro on OS X Lion with an NVIDIA Geforce GTX 285. It is crashing on launch, and seems to be a CUDA issues. It seems that there is a new NVIDIA driver in Lion, as it is listed as 270.05.05f01, while the most recent NVIDIA drivers on their web site is 256.02.25f01. And checking the CUDA Preferences it lists the current CUDA Driver 4.0.19 but says an Update is Required (though it is the latest CUDA for Mac Driver on NVIDIA’s Web site).

Since this is the relevant part of the crash log, it looks like a CUDA crash to me:

0   libcuda_270.05.00.dylib           0x000000011769286f cuGraphicsGLRegisterImage + 435983

1   libcuda_270.05.00.dylib           0x00000001176c1e25 cuGraphicsGLRegisterImage + 629957

2   libcuda_270.05.00.dylib           0x000000011766efa9 cuGraphicsGLRegisterImage + 290377

3   libcuda_270.05.00.dylib           0x0000000117669a8b cuGraphicsGLRegisterImage + 268587

4   libcuda_270.05.00.dylib           0x0000000117671b0c cuGraphicsGLRegisterImage + 301484

5   libcuda_270.05.00.dylib           0x000000011766e2a7 cuGraphicsGLRegisterImage + 287047

6   libcuda_270.05.00.dylib           0x00000001176372f2 cuGraphicsGLRegisterImage + 61842

7   libcuda_270.05.00.dylib           0x0000000117637caf cuGraphicsGLRegisterImage + 64335

8   libcuda_270.05.00.dylib           0x00000001176d83c8 cudbgGetAPIVersion + 86952

9   libcuda_270.05.00.dylib           0x000000011762715c cuGLCtxCreate_v2 + 108

10  com.adobe.GPUFoundation.framework    0x000000010cf3fe4c GF::Device::InitializeContextAndLoadKernels() + 1948

11  com.adobe.dvacore.framework       0x0000000100190b3e dvacore::threads::ExecuteTopLevelFunction(dvacore::threads::Allocated FunctionT<boost::function<void ()()> > const&) + 46

12  com.adobe.dvacore.framework       0x0000000100190438 dvacore::threads::(anonymous namespace)::WrapGCDAsyncCall(void*) + 24

13  libdispatch.dylib                 0x00007fff8f9887e9 _dispatch_worker_thread2 + 255

14  libsystem_c.dylib                 0x00007fff8b2913da _pthread_wqthread + 316

15  libsystem_c.dylib                 0x00007fff8b292b85 start_wqthread + 13

This looks like it is a driver issue with the new Lion Drivers for the Geforce GTX 285.

The only way I was able to get Premiere to launch was getting rid of the 5.5 folder from the Application Support:Adobe:Premiere Pro: folder. The program launched, but would not show any video in the sequence or from any clips, and once I quit the program, when I tried to relaunch I got the same crash again.

Please perform a CUDA update through the preference pane. We are pushing a new driver to the developer site shortly, but the updater already has the new .21 driver.

Developer Drivers (4.0.21) for Lion support have been posted to our developer site.
http://developer.download.nvidia.com/compute/cuda/4_0/drivers/devdriver_4.0.21_macos.dmg

I installed the new CUDA driver, but Premiere is still crashing, and the crash log looks the same.

I have exactly the same issue, installed the .21 driver and Premiere CS 5.5 crashes while starting, tried different alternatives with no luck. When I uninstalled Cuda, Premiere worked again (mercury playback engine software mode only).

Confirmed for me as well. Removing the CUDA framework from my Library and Premiere Pro launches, but without CUDA support, basically making my GeForce GFX 285 useless.

If your MacPro a 4,1? I have a MacPro4,1 Quad-Core 2.26x2. Someone on the Adobe forums is saying they are having no problem with a 3,1

I can not comment on if this a genuine bug or not, however, if you want to file a ticket so that NVIDIA engineering will look and respond, then you can do so by signing up to become a CUDA Registered Developer.

You can find the links to the application form here:
http://developer.nvidia.com/join-nvidia-registered-developer-program

Please do complete all the fields - real people do review the applications :)
Once you join you will be sent details on how to login into our developer portal, and once in you will find links to the bug filing form near the top left of the portal.

Good Luck - and Thanks,
-Nadeem

Check to see if you are booting 10.7 in 32 bit mode. If so, switch to 64 bit and your problem should be solved.

Nope, I am in 64 bit mode.

Hi, I uninstalled the previous version of Cuda, rebooted the computer, installed the new developer drivers, rebooted and launched OS X while holding 6 + 4 to boot the 64 bit kernel and I can confirm in my computer GTX285 is working with Premiere CS 5.5. I just got to find a way for Lion to boot in 64bit mode by default.
I’m running a Mac Pro 2 x 2.26 Quad Core with 24Gb of memory.

jonalee,
Are you using Adobe Premiere Pro CS5 version 5.5?

We reproduced the bug in 32bit mode.
The workaround until the bug is fixed is to boot the machine in 64bit mode.

For those who wish to boot up into Lion in 64-bit mode, here is a KBA describing the process:

http://support.apple.com/kb/ht3773

To select the 64-bit kernel for the current startup disk, use the following command in Terminal:

sudo systemsetup -setkernelbootarchitecture x86_64

Yes 5.5, and thanks for the terminal command to go around the issue for the moment.

Any word on this other than forcing the 64 bit kernel?

I was hoping the new Premiere Pro CS5.5 5.5.1 and Lion 10.7.1 would fix my CUDA issues with my GeForce GTX 285, but after upgrading to Premiere Pro 5.5.1 I had to upgrade my CUA to 4.0.5.0 and my GPU Driver is listed as 7.4.10 270.05.05f01. Previously I had gotten Premiere Pro to work by forcing the mac into 64 bit, but now I am getting no CUDA support (premiere pro runs, but software only). I am still running in the forced 64 bit Kernel, but since that was the only way it worked before I assume it will still work, but I will try rebooting into the 32 bit kernel and see if there are any changes, but as of now I am once again SOL with Premiere Pro and my GeForce GTX 275 for CUDA support.

Nope switching to 32 bit mode didn’t help.

Fixed it, this time a complete uninstall and re-install of the Adobe Suite fixed the issue. Thanks!