Problem with 4K@60Hz in Linux using T1000 video card


already have tested different drivers and different devices (monitors/plugs) but still have some sort of random problems with using 4K@60Hz modes.

I’ve found that I can’t create more than two 4K@60Hz X screen with any more recent driver than 470, ok, tried to use this version. Configuration can be created now and started but sporadically one or two channels of video cards not provide useful output to monitors (screens created, content ‘displayed’ on them and can be grabbed from frame buffers, but monitor says ‘check source power’ message). If I restart X few times I can have all monitors worked, but next restarting will leave one or two channels not functional again.
Problem not exist if I use 30Hz modes or resolution lower than 3840x2160.
But according to T1000 spec it must handle 4 4K@120 so I continue investigation.
I understood that this can be hard problem to solve as I already posted some related questions on this forum without solution. So try to start here from the other side and in small steps:

Can anyone suggest mDP to HDMI adapter which can be used for 4 4K@60 output for T1000 card?

(we currently use such adapters:

Thank you.