Problem with latest Drivers requred by CUDA Some NVIDIA drivers will not run after intalling latest

I have installed the latest drivers for my Geforce 9800 GT, and now some of the NVIDIA samples will not run. I am running Windows Vista Ultimate 32 bit, Service Pack 1. This is running on Intel Duel Core, 2.8 Ghz. Also, this is a new system that I have built recently. All of the components/hardware are new.
In the NVIDIA Direct3D SDK, the following samples run: Screen Space Ambient Occlusion, Skinning with Dual Quaternions, Skinning with Dual Quaternions, Skinning with Dual Quaternions, Skinned Instancing, Skinned Instancing, and SoftShadows. The rest of the D3D Samples open, but the window is black, nothing in rendering. I can tell somthing is happening though because in the Lightning sample, I can make screenshots, and the screenshot picture files show as if nothing in wrong (even though in the actual sample nothing in displayed on the screen).
In the NVIDIA OpenGL SDK, there is only one sample that does not work, and that is the Xmas Tree sample. This one does not start up. I was able to interest the errors is give, and they are as follows:

Unable to load the necessary extensions
Open GL Version 2.1

Now the driver version in 182.08 (2/18/2009). The old driver that I had installed (windows went out, found it and installed it) was dated 10/2/2008 (I do not know the version of this one). When I had the old drivers installed, all of the samples in the NVIDIA D3D SDK and NVIDIA OpenGL SDK worked without any problems, but the CUDA samples did not work. Also note all of the samples from the March 2009 DirectX SDK work with both drivers without any problems (including those requiring geometry shaders).

So my question is, does this indicate the latest drivers, version in 182.08 (2/18/2009) are defective?

Just an update. Tried the latest beta drivers, 182.46, and experienced the same problem.