Problem with Omniverse installation, permission to open denied

I tried installing the cache and starting a simple server but the connection broke so I had to restart it, and when I restart the download / installation it seems that the file is already in the appdata/local/ov folder but I can’t open it…
I am installing it as the admin of the PC, and I can’t even delete or open the file my self in this directory. It seems that permissions weren’t set properly because of the download break.
Here is the message I have when installing the server

I installed the ue4.26 connector and it works great so it’s not a problem of windows user on the workstation
Thanks in advance for your help

For the community: I restarted omniverse launcher and it works fine now

1 Like

Moving this topic to the Omniverse forum for visibility.

After doing it a lot I still get stuck on big downloads after a second or two of download, it freezes and doesn’t download more, any idea why?
My internet connection is still pretty stable