Cannot install Cache

I have installed the Omniverse launcher and from there installed Drive, Create, a bunch of connectors and even created a collaboration server on localhost… but from day one until just a few minutes ago, I simply cannot install Cache 1.5.3.

It simply fails all the time saying: Error occurred during installation of Cache. Command failed: “D:\Omniverse\Library\cache 153\setup\cache-setup.exe” -i -c “D:\Omniverse\Cache”.

Mind you, I am still very new to the Omniverse and only now starting to play around with it with an eye on making this my default workflow if it all pans out. Since I am this new it is likely that I am just doing something stupid but, for the life of me, with everything else installing just fine I have no idea what this thing’s problem is and that error message is absolutely all I have to go on.

1 Like

hi @mybadstudios, sorry to hear that you are having difficulties installing Cache. Can you provide us some information such that we can help get this resolved.

  • Do you have admin rights for installation?
  • Can you share with us the installation logs?

Logs are located here: C:\Users\ “windows username” \ .nvidia-omniverse\logs

Please compress the entire folder and upload them to the discussion.


I’m trying repro your issue, but I’ve had no luck so far unfortunately. I’m using Launcher 1.0.38 and was able to install Cache 1.5.3 to my D: drive.

Do you have access to System Monitor? If you open localhost:3080 in a web browser you can use System Monitor to configure Cache settings.

Is your Launcher up to date? Latest is currently 1.0.38 and you should have gotten a notification to update if you haven’t already.

Does changing the install location for cache do anything? Install location can be changed from Settings, by changing Library to a different path. From the looks of it, you currently have it set to D:\Omniverse\Library.

Okay so this is weird… I located that logs file and had a look inside. It would be a total waste to send it to you since the entire file is just this over and over

[2021-01-05 06:46:12.107] [info] Checking for update
[2021-01-05 06:46:12.146] [info] Update for version 1.0.38 is not available (latest version: 1.0.38, downgrade is disallowed).
[2021-01-05 06:46:12.146] [debug] No updates. Checking for an update in the next 60 seconds…
[2021-01-05 06:47:12.147] [info] Checking for update
[2021-01-05 06:47:12.195] [info] Update for version 1.0.38 is not available (latest version: 1.0.38, downgrade is disallowed).
[2021-01-05 06:47:12.196] [debug] No updates. Checking for an update in the next 60 seconds…

I can’t imagine anything being out of date since I only installed everything about a week or so ago. This means I downloaded everything on the same day so it is highly unlikely that anything would be out of date. As for admin rights, it is a single user PC… the admin account is the only account on this PC so, definitely have admin rights.

Next up I went to localhost:3080 and took a screenshot of what was there (everything running under Applications, nothing installed under Cache) so I could show you and maybe you could see something was missing…

Next I tried to install Cache once again so that if it DOES make any entry in the logs then it will be at the end and easy to spot when I send you the logs.

…this time Cache installed without any problems. 🤷‍♂️ I have no explanation for it. The only thing I did differently this time was going to the Connections tab and actually STARTING my connection to localhost before I tried to download and install Cache. That sounds like it might have something to do with it… also, not really. But maybe?

In any event, it is installed now so all is well.
Just in case, I am uploading my logs anyway in the hopes it might prove useful in finding out why this happened and possibly preventing it in future installs. (647.5 KB)


The entry in the logs regarding “Checking for update” is expected. Thank you for providing logs. Glad you were able to get Cache installed. We will investigate further to see if we can pinpoint the root cause such that it does not happen in the future. In the meantime, enjoy Omniverse and let us know if you have any other questions.

1 Like

Same problem happening for me.
I can’t install cache.

I keep uninstall and installing it, but it is failing.

os : windows

error massege :
Error occurred during installation of Cache: EPERM: operation not permitted, open
‘C:\Omniverset_test\library\cache2.0.1\System Monitor\aiohttp_frozenlist.cp38-win_amd64.pyd’

at ChildProcess.exithandler (child_process.js:312:12)
at ChildProcess.emit (events.js:310:20)
at maybeClose (internal/child_process.js:1021:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)

[2021-02-17 01:16:21.897] [error] Error invoking remote method ‘nucleus-install’: Error: Command failed: “D:\ov\pkg\collaboration\nucleus-workstation 2020.3.1\setup\nucleus-setup.exe” -i -d “D:\ov\data”

@jinbeom7029 @kyzhao a couple of questions

  1. What Windows OS are you using. (use winver program to get this info)
  2. Did you configure the Windows OS with a language other than English? If so which language?

Windows 10, Chinese. When I change it to English, it works…

This issue should be resolved with latest version of Nucleus on the Launcher R7 Hotfix (2020.3.2)

I have been running into the same issue of not being able to install the cache app within the Omniverse framework. I work at a large corporation so I am confident that it relates to part of the locked down configurations we run under, but since Omniverse is targeted to be an Enterprise level solution, I would think that a strategy would be in place to accommodate this kind of scenario.

When I did a full uninstall/reinstall of Omniverse today and looked at the launcher.log, I saw that it has a variety of errors. How do I best work with our IT Support to trouble shoot this?

Today, I have done the following:
• Completely uninstalled the Ominverse Framework
• Deleted / renamed the old application logs
• Re-downloaded the latest Ominverse installer
• Made sure video driver was the recommended compatible version
• Rebooted and did a clean install
• Attached launcher.log file

System Specs:
• OS Name Microsoft Windows 10 Enterprise
• Version 10.0.19041 Build 19041
• System Manufacturer LENOVO
• System Model 20USS07V00
• System Type x64-based PC
• System SKU LENOVO_MT_20US_BU_Think_FM_ThinkPad T15g Gen 1
• Processor Intel(R) Core™ i7-10850H CPU @ 2.70GHz, 2712 Mhz, 6 Core(s), 12 Logical Processor(s)
• Locale United States
• Installed Physical Memory (RAM) 32.0 GB
• Graphics Card NVIDIA GeForce RTX 2080 Super with Max-Q Design (2.2 KB)

@kevin.merino - Sorry for the problems you are having with installing Omniverse components. Your debug steps and data collection were exquisite!

The issue is that the current Omniverse installer and some of the bundled products requires an admin privilege level account (not just elevated privilege from a standard user account). Thus you must use the current beta version from such an admin account to get the various components to install.

You are also correct in that Omniverse in an Enterprise level solution must account for both admin and standard users. In addition, standardized IT distribution of Omniverse (individual components, updates and locked versions) must also be provided. These updates are coming soon (I cannot provide and exact date).

So the only work-around at the current time is to install using a Windows account that has admin rights. Your hardware/software inventory matches the requirements for Omniverse.

1 Like

@mirice Thank you for your evaluation of my scenario and input!

Kind Regards!