Problem with reinstalling OS in Jetson AGX Xavier


I received my Jetson AGX Xavier with preinstalled system. I would like like to boot and reinstall the system. I’ve been trying to do it in many ways but I always have some issues and don’t know how to deal with them. The easiest way should be to do it using SDK manager. I install different types of ubuntu and try to install SDK manager but each time it says „unmet dependencies”. What should I do? By the way, is it normal to get a brand new jetson with preinstalled system?

Best regards,

JetPack/SDK Manager is a front end to the flash software, all of which runs on the Ubuntu desktop PC (Jetsons, and most embedded systems, don’t have a BIOS, and so they need a helper computer to flash). The dependencies are part of the host PC and not the Jetson for this case.

Just install the dependencies on the host PC. An example of updating the host PC prior to adding new software:

sudo apt update
sudo apt-get upgrade

An example dependency:

sudo apt-get install libncurses5-dev

If you get a dependency missing, just post here what the dependency is. There is a strong chance that you could just install that dependency by substituting that name for the above example package name “libncurses5-dev” (this one is used for kernel building, and won’t actually be required for flash, but is useful for a lot of things related to a Jetson). Also, SDKM can export logs, and you could post that. Be sure to mention which release of SDKM you are using.

Thank you so much! After updating dependencies everything works fine now😊

While trying to flash the system using SDKM another issue has appeared. I all the time get information that the target is in bad state and I have to manually put it into recovery mode. Either I am doing something wrong with putting it into that mode or there is another issue. I have also tried to flash jetson with automatic setup but there is an error: incorrect username and password, although I normally can log into the system. If I change the OEM Configuration to runtime I get an error saying cannot connect to the device via SSH. What can be the problem?

Is this a native Ubuntu host PC? Or is it a VM? Are you using the full JetPack/SDK Manager to install via GUI, or are you using command line?

You might find it useful to know that in recovery mode the Jetson is a “custom USB device”, and is understood by the “driver package” (which is what JetPack/SDKM runs). Once the flash itself completes, then the Jetson automatically reboots for first boot login account setup. Reaching that step means flash finished, but the extra content was not installed by flash; once that first boot setup is done, the extra content is installed over ssh, and thus the first boot login account must exist. It might be flash which fails, or it might have finished flash and failed first account setup, and this is what I am thinking about. If flash completed, then you can solve first boot login issues without flashing again, and then use JetPack/SDKM (after unchecking flash) to install specific optional components.

Beyond the above questions, can you get a serial console boot log? This often gets around first boot setup issues if it is just the GUI failing. The log would point out more specifically what is actually failing, plus give you a second method to complete first boot setup.

It is native Ubuntu. I had tried to flash on vm but couldn’t even install SDKM, so I changed to native OS. I am using SDKM to install via GUI.
When I normally turn on/boot jetson the boot log says: [failed] Failed to start PM2 process manager. Despite that everything is [OK]. How to fix it?

This PM2 failed log probably has been appearing since the first boot of the jetson which had the system already preinstalled. Can it be the reason of problems? I also had the issues with setting up a server and running a node on it. That’s why I decided to reinstall the whole system to install everything correctly.

Which JetPack/SDK Manager release is being used?

Is this an AGX Xavier dev kit? If so, can I ask you to try command line flash, with logging, and post the log? From the “Linux_for_Tegra/” directory (basically “~/nvidia/nvidia_sdk/JetPack...version.../Linux_for_Tegra/”) this would log and flash:
./ jetson-xavier mmcblk0p1 2>&1 | tee log_flash.txt

FYI, the above simplifies flash requirements and does not use the GUI, and it also does not install optional components, but those components could be installed later. It is easier to just install components once flash is successful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.