Problems to Install Linux Driver for NVIDIA Quadro P4000 in ubuntu 16.04

I’m trying to install the driver of the Nvidia Quadro P4000 in a workstation but for the moment i’m not able to make it works

  1. First I tried to enable the Nvidia Driver form the GUI through System-Settings–> Software & Updates–>Additional Driver: it enable the drier 384.130 but it completely destroy the system that after that start in Rcovery mode.

  2. I have reistalled the System and i wanted to try to install the proprietary driver downloaded by Nvidia: NVIDIA-Linux-x86_64-390.87.run

  • Under /etc/modprobe.d i have added a blacklist-nouveau.cfg with the following two line blacklist nouveau and options nouveau modeset=0
  • i have run this command sudo update-initramfs -u to regenerate initramfs
  • The in the terminal i have stopped the lightdm service with sudo service lightdm stop
  • The i tried to run ./NVIDIA-Linux-x86_64-390.87.run

But it pre-install script failed with the following erroer:

Unable to load: nvidia-installer ncurses v6 user interface

there is method to fix or i made some mistake? Below there is the complete log file

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon Oct  8 17:11:49 2018
installer version: 390.87

PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/snap/bin

nvidia-installer command line:
    ./nvidia-installer

Unable to load: nvidia-installer ncurses v6 user interface

Using: nvidia-installer ncurses user interface
-> Detected 8 CPUs online; setting concurrency level to 8.
-> Installing NVIDIA driver version 390.87.
-> Running distribution scripts
   executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> The distribution-provided pre-install script failed!  Are you sure you want to continue? (Answer: Abort installation)
ERROR: Installation has failed.  Please see the file '/var/log/nvidia-installer.log' for details.  You may find suggestions on fixing installation problems in the README available on the Linux driver download page at www.nvidia.com.

The error of the .run installer is expected, it means that you already have a driver installed. Please don’t use the .run installer, instead use the graphics ppa
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
to get a more recent driver. If it still fails, please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

Tanks for the help.

I’m new about linux so i make a lot of confision with linux driver. Just to understand, the driver in that repo are official driver provided by Nvdia or Compatible Driver?

Tomorrow i will try to install using that repo. However just related to the error, you told me already a driver was installed, It was a fresh installation so the driver was default nouveau driver that i though to remove adding in blacklist… is not correct?

The repo driver is the same driver as the .run installer but repackaged to fit for your system so you don’t break anything. It also takes care of blacklisting nouveau.
The .run installer you can download at Nvidia’s site is for advanced users with specific needs and the base for the repo drivers.