problems with cuda 3.0, devdriver 195.36.15 on ubuntu 10.04


when i try to execute the sdk example i receive this error :

andrea@andrea-desktop:~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release$ ./smokeParticles 

 [ CUDA Smoke Particles ]

 freeglut (./smokeParticles):  ERROR:  Internal error <FBConfig with necessary capabilities not found> in function fgOpenWindow

 X Error of failed request:  BadWindow (invalid Window parameter)

  Major opcode of failed request:  4 (X_DestroyWindow)

  Resource id in failed request:  0x0

  Serial number of failed request:  30

  Current serial number in output stream:  33

my configuration is : GeForce250GTS 1GB, devdriver 195.36.15, cuda 3.0, Ubuntu 10.04

anyone could help me?

thank you


Weird, I have never seen anything like this. I am using OpenSuSE 11.2 and it worked for me both with 3.0 and 3.1 beta. It does however not work, if you run over a network - I just tried (via ssh) and get the message “Required OpenGL extension missing”. Is your X set up properly? It looks more like a problem with X than with CUDA.

Or maybe with your freeglut?

actually when i click on 'system->preferences->NVIDIA-X-Server-Settings nothing happens…I mean it doesn’t open the panel.
what could be wrong? when i installed the driver i clicked ‘ok configure X server settings!’

You could try reinstalling the nvidia driver.

The problem you’re encountering typically happens if you install something like libglu which overwrites some of the files from nvidia’s driver.

If this is the case, you probably see a mention of mesa near the top of the /usr/include/GL/gl.h file and you need to reinstall the driver.


thanks for replies!