Problems with CUDA in Seven 64 bits Visual Studio, Opengl etc

Hi everyone!

I have on my computer a gtx275 so i would like to use it to lean CUDA.

I also have installed all softwares about CUDA programmation like drivers, toolkits and SDK but when i try to run some programm who use OpenGL to display graphics, i just have a blank windows!

For example, when i run particle programm, the soft opened a windows but you cannot see anything on it (the first time i run the computation it’s works but after Opengl seems to have disappears from my computer) but the programm effectively run (you can the fps and the flops performance rate)

I also have a problem with D3D10, some example who use it crash all the time!

So this is my first problem with CUDA.

The second problem concern Visual Studio 2008. When i open a solution with .cu files, VS don’t recognize it like it recognize C++ langage (colors etc). You can just see the .cu file as if it will be written in worpad.

I see in the forums that it could be a linking problem.

So how to resolve this problem?

ps: It’s hard from me to well understand CUDA and how to praticse whith it considering im french. You do not in france support for this technologie, so i have to deal with english publications who mades me very incorfortable (lot of technical terms that i have to understand well about the Gpu itself and the API)

ps2: Sorry for my bad expression in english, feel free to question me for you to have more explanations if i am misunderstood.