Problems with Opencv4Tegra.

Hello, I installed everything with Jetpack and it seems that CUDA is running fine but I can’t say the same with Opencv.

I tried some examples codes but when compiling it says that most of the functions are not defined. Is there something left for me to do?

Hi James_Sac,

Which version of JetPack you’re using? And what examples you tested?

Thanks

I’m using the 2.3.1 version alonside those examples referenced at linuxwiki…

http://elinux.org/Jetson/Installing_OpenCV

https://sourceforge.net/projects/opencvlibrary/files/opencv-unix/2.4.9/

I followed all the steps to install the jetpack package and everything seems to be fine but I have no idea if Opencv is installed or not. cv and std are not being recognized by the compiler.

If opencv4tegra is installed, it is in /usr :

ls -d /usr/include/opencv*
/usr/include/opencv  /usr/include/opencv2

ls  /usr/lib/libopencv*
/usr/lib/libopencv_calib3d.so
/usr/lib/libopencv_calib3d.so.2.4
/usr/lib/libopencv_calib3d.so.2.4.13
/usr/lib/libopencv_contrib.so
/usr/lib/libopencv_contrib.so.2.4
/usr/lib/libopencv_contrib.so.2.4.13
/usr/lib/libopencv_core.so
/usr/lib/libopencv_core.so.2.4
/usr/lib/libopencv_core.so.2.4.13
/usr/lib/libopencv_detection_based_tracker.so
/usr/lib/libopencv_detection_based_tracker.so.2.4
/usr/lib/libopencv_detection_based_tracker.so.2.4.13
/usr/lib/libopencv_esm_panorama.so
/usr/lib/libopencv_esm_panorama.so.2.4
/usr/lib/libopencv_esm_panorama.so.2.4.13
/usr/lib/libopencv_facedetect.so
/usr/lib/libopencv_facedetect.so.2.4
/usr/lib/libopencv_facedetect.so.2.4.13
/usr/lib/libopencv_features2d.so
/usr/lib/libopencv_features2d.so.2.4
/usr/lib/libopencv_features2d.so.2.4.13
/usr/lib/libopencv_flann.so
/usr/lib/libopencv_flann.so.2.4
/usr/lib/libopencv_flann.so.2.4.13
/usr/lib/libopencv_gpu.so
/usr/lib/libopencv_gpu.so.2.4
/usr/lib/libopencv_gpu.so.2.4.13
/usr/lib/libopencv_highgui.so
/usr/lib/libopencv_highgui.so.2.4
/usr/lib/libopencv_highgui.so.2.4.13
/usr/lib/libopencv_imgproc.so
/usr/lib/libopencv_imgproc.so.2.4
/usr/lib/libopencv_imgproc.so.2.4.13
/usr/lib/libopencv_imuvstab.so
/usr/lib/libopencv_imuvstab.so.2.4
/usr/lib/libopencv_imuvstab.so.2.4.13
/usr/lib/libopencv_legacy.so
/usr/lib/libopencv_legacy.so.2.4
/usr/lib/libopencv_legacy.so.2.4.13
/usr/lib/libopencv_ml.so
/usr/lib/libopencv_ml.so.2.4
/usr/lib/libopencv_ml.so.2.4.13
/usr/lib/libopencv_objdetect.so
/usr/lib/libopencv_objdetect.so.2.4
/usr/lib/libopencv_objdetect.so.2.4.13
/usr/lib/libopencv_photo.so
/usr/lib/libopencv_photo.so.2.4
/usr/lib/libopencv_photo.so.2.4.13
/usr/lib/libopencv_stitching.so
/usr/lib/libopencv_stitching.so.2.4
/usr/lib/libopencv_stitching.so.2.4.13
/usr/lib/libopencv_superres.so
/usr/lib/libopencv_superres.so.2.4
/usr/lib/libopencv_superres.so.2.4.13
/usr/lib/libopencv_tegra.so
/usr/lib/libopencv_tegra.so.2.4
/usr/lib/libopencv_tegra.so.2.4.13
/usr/lib/libopencv_ts.a
/usr/lib/libopencv_video.so
/usr/lib/libopencv_video.so.2.4
/usr/lib/libopencv_video.so.2.4.13
/usr/lib/libopencv_videostab.so
/usr/lib/libopencv_videostab.so.2.4
/usr/lib/libopencv_videostab.so.2.4.13
/usr/lib/libopencv_vstab.so
/usr/lib/libopencv_vstab.so.2.4
/usr/lib/libopencv_vstab.so.2.4.13

Hi James,

The openCV works on TK1/R21.5.
You can following below steps to check your openCV function:

Yes, it was succesfully installed. Thank you so much Honey and carolyuu.