Programmatically attaching joint via robot assembler

following the tutorial descried in
I wanted to attach the Robotiq_2F_140_physics_edit to the UR10e. Using the code I always end up with a Gripper at the right position, but, when pressing play, it just falls off.
Other approaches by adding rigid links worked, but when pressing play the whole robot rotates 90 degrees.
Why is it so hard to just attach a gripper?
Adding the gripper to the prim path of te UR10e leads to a wrong articulation.
My goals is to just attach the gripper and control the robot and the griper separately via ROS2.


Hello Heiko,
Even I am trying to use the robot assembler to attach the Robotiq 2f140 gripper to a Kuka LBR iiwa robot but after attaching I am getting a missing references error in the console. Can you please share me the code ?

In my case the attachment is fine the gripper is not falling off.


Hi tribikram,

I just took the example from the documentation
and was not able to assemble the robot and the gripper. The main reason for me was using the Robotiq gripper from the Nucleus assets library. This model has some strange indirect asset references, which made it impossible for me to use with the robot assembler. I used therefore a self-imported URDF of the gripper. However, I still get reference error.
So, I still have no solution. However, you still can use the assembly despite the error.