Pwm0 enable/disable on jetson Tx2 3GB

How to enable pwm0 on jetson TX2.

right now i am doing below steps

cd /sys/class/pwm/pwmchip0/pwm0
echo 20000 > period
echo 10000 > duty_cycle

is there any other method to enable pwm0 in which we dont require to export
echo 0 > /sys/class/pwm/pwmchip0/export.

can you please help here.

hello anupam.kumar,

you may use below commands to enable PWM.
i.e. $ echo <channel_no> > /sys/class/pwm/pwmchip0/export

please note that,
there is an upper and lower limit value supported based on controller’s clock source and the frequency and pulse divisor values.
you may configure period_val period in nano second; duty_width to set duty width in nano second.

Hi jerry,

is there any method in device tree to enable pwm0,i dont want to use

echo <channel_no> > /sys/class/pwm/pwmchip0/export

in my opinion this should be automatically exported during after device bootup,can we make it auyomatic in device tree?

hello anupam.kumar,

you may have pinmux customization for update your board configuration.
please also check developer guide, Jetson TX2 Platform Adaptation and Bring-Up for reference,