PWM1 not working on jetson tx2

I am using GP_PWM1 for pwm purpose of led.

when i am writing to this register,system reboots.

can anybody help how we can enable it.

platform/3280000.pwm, 1 PWM device
pwm-0 ((null) ): period: 0 ns duty: 0 ns polarity: normal

I am writing on 0x3280000 register for brightness set and then reading.

hello anupam.kumar,

according to pinmux spreadsheets, you’re working with module pin, LCD0_BKLT_PWM, right?
you may also check developer guide, Jetson TX2 Series MB1 Platform Configuration for PWM commands.

ye working on LCD0-BKLT ,on this pin IR led is attached.

how i can control pwm of this irled,.

I am able to write PWM value on 3280000 address but when i am reading it,it is crashing.
any help will be appreciated.

how to measure rpm of pwm-fan

cat /sys/devices/pwm-fan/rpm_measured

i am getiing its value as zero,pwm-fan is enabled by default,how we can measure rpm_measured

root@localhost:/home/ubuntu# echo 1 > /sys/devices/pwm-fan/tach_enable
bash: echo: write error: Operation not permitted

how to enable pwm-fan so that we can set its parameters.

hello anupam.kumar,

you may check fan rpm through hw monitor, please also check Topic 128331 for reference,

    echo 1 > /sys/devices/pwm-fan/tach_enabled

how to enable this fan?

cat /sys/devices/pwm-fan/rpm_measured i am getting rpm_measured as zero value