Q4000 updated driver 256.02.25f01 break CUDA 4.0

Hello,

I am running a Mac Pro 10.6.8 64bit 12-core machine with two Q4000 mac GPUs and i just installed the new nvidia driver, 256.02.25f01, released today. Now my CUDA 4.0 development is broken. I reinstalled the display driver, then cuda driver, cuda toolkit, and cuda sdk but still i am getting this error,

/Developer/GPU Computing/C/bin/darwin/release $ ./deviceQuery
[deviceQuery] starting…
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
[deviceQuery] test results…
FAILED

Press ENTER to exit…

When i check the current driver running i get the correct, 256.02.25f01 display driver.

PLEASE HELP, i need my results for thesis completion.

Thanks!!!

I have the same problem, I am using Mac OS X Lion 10.7 Release 4 and the Cuda applet in Preferences has the following message, see attached file:
CUDA.jpg

CUDA.jpg

Based on my tests Mac OS X 10.6.8 works fine with the old driver 256.01.00f03, I had to revert back and CUDA is now working fine, as soon as I will upgrade to the new one it will stop working. I’ve validated that as well with Adobe Premiere Pro CS5.5, 10.6.8 + Old Quadro driver + CUDA 4.0.17 works perfect in Premiere with GPU acceleration.

How did you rollback to the March 2011 driver?

When I try this rollback, I get the message the stops me from doing so: “No Driver Update Needed - This system already has driver which support the NVIDIA graphics solution.” Only option is Close.

You have to use the old drivers from 03/22, open the package and inside there are 3 more packages, Video, Display and OpenGL, install each of them reboot and you will all set.

This would be the link for the old driver?

Sorry wrong link

I think there is a newer one,

Seems like a pretty sick joke or something,

Exact same code, and linked libraries.

Macbook pro 3.06Ghz intel core 2 duo, 8GB memory, 10.6.8, 9600m GPU, CUDA 4.0.17
Starting fft_GPU
Complete fft_GPU RunTime:time:0.34s
Starting GPU_recon
Complete GPU recon RunTime:time:4.04s

Mac Pro 12-core 2.66Ghz, 64GB memory, 10.6.8, dual quadro 4000s, CUDA 4.0.17, 256.01.00f03
Starting fft_GPU
Complete fft_GPU RunTime:time:7.46s
Starting GPU_recon
Complete GPU recon RunTime:time:6.57s

Very sad :-(

Nvidia seriously fix this!!! I have several quadroplex units, quadro 6000’s, 5800’s, common guys.

New results after driver fix and cuda update
Mac Pro 12-core 2.66Ghz, 64GB memory, 10.6.8, dual quadro 4000s, CUDA 4.0.17, 256.02.25f01
Starting fft_GPU
Complete fft_GPU RunTime:time:0.25s
Starting GPU_recon
Complete GPU recon RunTime:time:1.33s

Had a bad crash on the old driver, CUDA functioned just not very well.

Now ive installed the new driver (june 24, 2011), cleared the pram 5 times and my second card is detected but says driver is not installed.

Any thoughts?

Thanks,

update: removed the second card, slot 2, rebooted and cleared pram. Shutdown, installed second card, booted and finally i have all q4000’s detected. CUDA doesnt work now, as the driver release and cuda version dont match.

Anyway, thats where im at.

We’ll be releasing new CUDA 4.0.19 drivers soon to restore full CUDA support for Quadro 4000 on 10.6.8:

http://www.nvidia.com/object/mac-driver-archive.html

No new 4.x version?

He must have meant 4.x, as 3.2.19 would be taking us back to pre 4.0 CUDA.

Fingers crossed, i guess i will resort to writing.

Thank you for the acknowledgement of the problem,

Sorry. Fixed sentence. Thanks for catching that. :)

Thank you, any estimates for release time frame ?

After a few hours of effort this morning with the new CUDA driver and the new display driver i can finally say i have everything working again.

Process i found that finally worked, was to
1)install only one quadro 4000,
2)reset the pram (option-command-p-r all at the same time during boot before the gray screen),
3)install the new driver, requires reboot,
4)after successfully rebooting, shutdown and restart to make sure card is still running at 16x pcie. I had troubles with this as it was only showing 4x,
5)shutdown,
6)install second quadro 4000 in slot 2 and restart machine,
7)verify both cards are running at 16x with displays connected,
8)shutdown, verify again,
9)restart, verify again, i had troubles with this not working only after restarts i reset the motherboard switch between the pci-1 and pci-2 16x slots and restarted entire process.
10)install new cuda driver,
11)run tests like convolvefft on device 0, then device 1,
12)if it doesnt crash ur done.

Good luck!!!

Sorry for the late update but we posted the new CUDA driver today:

http://www.nvidia.com/object/macosx-cuda-4.0.19-driver.html

Please could you explain how did you check that the card is running at PCI 16x ?, where I can get some instructions on how to run “convolvefft” ?, thank you

Apple System Profile gives this information in the graphics section.

am still having kernel panics

Kernel Extensions in backtrace (with dependencies):
com.apple.nvidia.nvGF100hal(6.3.7)@0x1c32000->0x21e7fff
dependency: com.apple.NVDAResman(6.3.7)@0x96e000
dependency: com.apple.iokit.IOPCIFamily(2.6.5)@0x928000
com.apple.NVDAResman(6.3.7)@0x96e000->0xc5efff
dependency: com.apple.iokit.IOPCIFamily(2.6.5)@0x928000
dependency: com.apple.iokit.IONDRVSupport(2.2)@0x961000
dependency: com.apple.iokit.IOGraphicsFamily(2.2)@0x93f000

somebody figured this out yet?

i desperately need support! I tried everything there is…still have kernel panics! help NVIDIA

Likewise, im pretty unstable if i use two cards. Ive switched to testing on another machine,

Please Nvidia, help us out. We invested in two of your Quadro 4000s because u said they work, so please get them working!!!

Thanks in advance,