Quadro K1200 no longer recognizes specific monitor model after disabling via Ubuntu 14.04 display Ma...

I have a test system running Ubuntu 14.04 with the Quadro K1200 currently installed and connected to 2 monitors - a Dell U3014 and a EIZO EV2750.

Prior to this issue this set up was working fine.

In the process of trouble shooting an unrelated issue, I disabled the Dell monitor using the All Setting > Displays on/off toggle switch within Ubuntu.

This caused the Dell monitor to disappear from the Display manager preventing me from re-enabling it.

I then re-installed the OS, expecting this to revert the settings and both monitors to be enabled, it made no difference.

I have a number of both these monitor models to test with. I can connect a EIZO to each of the 4 Display ports and they all work as expected. If I connect any Dell U3014 to any DP the monitor is not detected.

Connecting only a U3014 and restarting the PC the monitor detects no output, not even during boot.

As best I can tell the U3014 monitors are not detected by the video card at all, there is no evidence of them being connected either in xrandr:

Screen 0: minimum 8 x 8, current 2560 x 1440, maximum 16384 x 16384
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
  2560x1440      60.0*+
  1920x1200      59.9  
  1920x1080      59.9  
  1680x1050      60.0  
  1600x1200      60.0  
  1600x900       60.0  
  1280x1024      60.0  
  1280x800       59.8  
  1280x720       60.0     59.9  
  1024x768       60.0  
  800x600        60.3  
  720x480        59.9  
  640x480        59.9     59.9  
DP-5 disconnected (normal left inverted right x axis y axis)
DP-6 disconnected (normal left inverted right x axis y axis)
DP-7 disconnected (normal left inverted right x axis y axis)

Or in the Nvidia X Server Settings.

This specific monitor model appears to have been disabled directly on the card, any thoughts on how I can reverse this?


nvidia-bug-report.log.gz (161 KB)

Any ideas folks?

Starting up with just 2 Dell U3014 connected I don’t get anything not even the POST, which makes me this there is a config item outwith the OS thats driving this.

I’ve had trouble in the past with some Dell monitors locking up. Have you unplugged or otherwise cut power to the monitor since this problem occurred? If not, please try unplugging the monitors from power, waiting a few seconds, and then plugging them back in.

We have a number of this model of Dell onsite. I’ve tried a few and none of them are recongised.

I’ve tried power cycling; turned the machine off, unplugged the power from the monitors left it for 5 min or so, plugged everything back in and booted up with just the Dell monitor connected. Still nothing, not even POST.


No other ideas?

Having reinstalled the OS and reset the BIOS to default, I can only assume that the configuration that is disabling this monitor model is stored directly on the card. Is this possible?

Tadpole, when you reset the PC’s BIOS to default did you first unplug the power supply and then tap the case’s power button to flatten the voltages in the power supply, on the motherboard and in any connected expansion cards?

Does that Dell monitor have a firmware factory parameter reset button perhaps accessible via a paper clip-sized hole?

No, nothing like that is stored on the GPU. Do these monitors work with other GPUs, and do other monitors work with the same port on the problematic GPU?

Edit: it would be good to swap out the cable too in case the cable went bad somehow.

Oh yeah, another probably dumb question: are you sure the monitor is on the right input? Some (mostly older) DisplayPort monitors show up as disconnected if you switch their input from DP to something else.