Really bad framedrops with the Linux 4.* kernel

Hi, in the 4.* kernel series I have serious issues playing games (or anything CPU intensive). The game in question (Borderlands 2, DotA 2, etc) seems to stall the CPU and threads actually fall off while the game for example tops off at 100% on the core it’s active on. This means that running twitch together with Borderlands 2 will effectively make the system unusable. The pattern is that these stalls happen once every few seconds.

I’m running Arch Linux, I’ve tried the stock kernel and the zen kernel to no avail. My hardware: Intel i7, 32GB RAM, GTX 680. I’m hoping anyone can help.
nvidia-bug-report.log.gz (193 KB)

I’m running Arch Linux with the 4.2.5 kernel, NVIDIA 358.16 and a GTX 580 , Intel Core i7 and Borderlands 2 works just fine on 1440p max settings.

Yes, I’m aware my problem seems to be rather unique. Hence I’m posting it here in hopes of finding out what the problem is. I have the same nvidia driver version (I updated the OS yesterday).

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1307473

I ran the test case as found in reply 1 and I get the same behavior. I’m however not running a VM. The stalls occur more heavily when I have Intel Turbo Boost enabled and they seem to occur more frequently when I run multiple flash applications or flash and a game.

I get the same behavior. After installing 358.16 on 4.3.0 kernel. With 348.11 works just fine.

This almost sounds similar to what I was seeing here (look at the videos I posted later in the thread)

https://devtalk.nvidia.com/default/topic/849880/stuttering-in-opengl-applications-mint-17-1-cinnamon-desktop

I never did figure out the cause but after unplugging my main video card, using my old one then re-installing my new one again everything fixed itself. Odd.

I’m bumping this.

Additionally, I made some changes to xorg.conf: removed refresh rates and disabled twinview. The issue is still there but less problematic. Framerate in CS:GO is still suffering however and the game is unplayable for me atm (unless I’m playing hide and seek in it).

Guys, I’m getting really nervous about this. Can someone from Nvidia at least confirm they have seen this or something?

One more try…

It seems the problem also occurs on the 3.18.24 kernel. I will try to 3.18.20 kernel.