Reboot on suspend2idle

I’ve written a bash script to automatically suspend my Nano 2GB (via the echo freeze > /sys/power/state method) since deep sleep isn’t enabled. After almost exactly a minute of idling, a reboot is automatically triggered without first waking up. This happens whether I suspend via my script or manually with the script disabled. The weirdest part is that if I wake the system before the minute mark it’ll still reboot around a minute after I suspended. Any ideas what might be causing this? or how to capture a log during idle before the reboot?
edit: running Jetpack 4.6

hello user56846,

you could setup the serial console to gather the serial logs, it’ll capture bootloader and kernel messages.
had you have peripheral devices connected? it might be the connected device sending wake-up events.

Tried to remove all peripherals, switched the power supply, did a fresh re-install, modified my script to de-activate the network manager while suspended, nothing worked. I’m guessing it has to be something about the board itself, the problem isn’t that it’s being woken up but that it’s automatically rebooting after it suspends. I don’t have a serial console unfortunately but here’s my syslog from a full suspend/reboot cycle:

Nov 23 22:08:43 usepit-usage-pit systemd[1]: Stopping Network Manager…
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.2834] caught SIGTERM, shutting down normally.
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.2956] device (rndis0): released from master device l4tbr0
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.2972] device (usb0): released from master device l4tbr0
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.2994] device (wlan0): state change: activated → deactivating (reason ‘unmanaged’, sys-iface-state: 'm$
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.3059] manager: NetworkManager state is now CONNECTED_LOCAL
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.3065] device (wlan0): state change: deactivating → unmanaged (reason ‘removed’, sys-iface-state: 'man$
Nov 23 22:08:43 usepit-usage-pit whoopsie[4816]: [22:08:43] offline
Nov 23 22:08:43 usepit-usage-pit dbus-daemon[4018]: [system] Activating via systemd: service name=‘org.freedesktop.nm_dispatcher’ unit='dbus-org.freedesktop.nm-dispatcher.servic$
Nov 23 22:08:43 usepit-usage-pit systemd[1]: Starting Network Manager Script Dispatcher Service…
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.3250] dhcp4 (wlan0): canceled DHCP transaction, DHCP client pid [xxx]
Nov 23 22:08:43 usepit-usage-pit NetworkManager[4220]: [1637723323.3250] dhcp4 (wlan0): state changed bound → done
Nov 23 22:08:43 usepit-usage-pit kernel: [ 4808.150934] wlan0: deauthenticating from [xxx] by local choice (Reason: 3=DEAUTH_LEAVING)
Nov 23 22:08:43 usepit-usage-pit dbus-daemon[4018]: [system] Successfully activated service ‘org.freedesktop.nm_dispatcher’
Nov 23 22:08:43 usepit-usage-pit systemd[1]: Started Network Manager Script Dispatcher Service.
Nov 23 22:08:43 usepit-usage-pit nm-dispatcher: req:1 ‘connectivity-change’: new request (1 scripts)
Nov 23 22:08:43 usepit-usage-pit nm-dispatcher: req:1 ‘connectivity-change’: start running ordered scripts…
Nov 23 22:08:43 usepit-usage-pit wpa_supplicant[4249]: wlan0: CTRL-EVENT-DISCONNECTED bssid=[xxx]reason=3 locally_generated=1
Nov 23 22:08:43 usepit-usage-pit avahi-daemon[3880]: Withdrawing address record for [xxx] on wlan0.
Nov 23 22:08:43 usepit-usage-pit avahi-daemon[3880]: Leaving mDNS multicast group on interface wlan0.IPv4 with address [xxx]
Nov 23 22:08:43 usepit-usage-pit avahi-daemon[3880]: Interface wlan0.IPv4 no longer relevant for mDNS.
Nov 23 22:08:43 usepit-usage-pit whoopsie[4816]: [22:08:43] Cannot reach: https://daisy.ubuntu.com
Nov 23 22:08:43 usepit-usage-pit avahi-daemon[3880]: Withdrawing address record for [xxx] on wlan0.
Nov 23 22:08:43 usepit-usage-pit avahi-daemon[3880]: Leaving mDNS multicast group on interface wlan0.IPv6 with address [xxx].
Nov 23 22:08:43 usepit-usage-pit avahi-daemon[3880]: Interface wlan0.IPv6 no longer relevant for mDNS.
Nov 23 22:08:43 usepit-usage-pit systemd[1]: Starting resolvconf-pull-resolved.service…
Nov 23 22:08:43 usepit-usage-pit wpa_supplicant[4249]: wlan0: CTRL-EVENT-REGDOM-CHANGE init=CORE type=WORLD
Nov 23 22:08:43 usepit-usage-pit systemd[1]: Started resolvconf-pull-resolved.service.
Nov 23 22:08:45 usepit-usage-pit nm-dispatcher: req:2 ‘down’ [wlan0]: new request (1 scripts)
Nov 23 22:08:45 usepit-usage-pit nm-dispatcher: req:2 ‘down’ [wlan0]: start running ordered scripts…
Nov 23 22:08:45 usepit-usage-pit NetworkManager[4220]: [1637723325.8456] exiting (success)
Nov 23 22:08:45 usepit-usage-pit wpa_supplicant[4249]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
Nov 23 22:08:45 usepit-usage-pit systemd[1]: Stopped Network Manager.
Nov 23 22:08:45 usepit-usage-pit kernel: [ 4810.775861] PM: suspend entry 2021-11-24 03:08:45.953591243 UTC
Nov 23 22:08:45 usepit-usage-pit kernel: [ 4810.775866] PM: Syncing filesystems … done.
Nov 23 22:08:45 usepit-usage-pit kernel: [ 4810.812290] PM: Preparing system for sleep (freeze)
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4810.933124] tegradc tegradc.0: blank - powerdown
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4810.984582] extcon-disp-state extcon:disp-state: cable 47 state 0
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4810.984584] Extcon AUX1(HDMI) disable
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.019404] tegradc tegradc.0: blank - powerdown
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.019421] tegradc tegradc.0: unblank
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.026841] tegradc tegradc.0: nominal-pclk:267810000 parent:267809375 div:1.0 pclk:267809375 265131900~291912900
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.026921] tegradc tegradc.0: hdmi: tmds rate:267810K prod-setting:prod_c_hdmi_150m_300m
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.028492] tegradc tegradc.0: hdmi: get YCC quant from EDID.
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.063427] extcon-disp-state extcon:disp-state: cable 47 state 1
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.063430] Extcon AUX1(HDMI) enable
Nov 23 22:08:46 usepit-usage-pit kernel: [ 4811.078764] tegradc tegradc.0: sync windows ret = 246
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.133170] tegra_dvfs: suspended
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.133175] Freezing user space processes … (elapsed 0.002 seconds) done.
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.136057] Freezing remaining freezable tasks … (elapsed 0.001 seconds) done.
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.137393] PM: Suspending system (freeze)
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.145096] usb usb2: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.145133] sdhci-tegra sdhci-tegra.0: Tuning done, restoring the best tap value : 19
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.151195] usb 1-2: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.160860] usb 1-3.2: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.172747] usb 1-3.1: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.192817] tegra-xusb-padctl 7009f000.xusb_padctl: power down UTMI pad 2
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.212803] usb 1-3: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.242850] usb usb1: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.242868] tegra-xusb 70090000.xusb: entering ELPG
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.244023] tegra-pmc: PMC tegra_pmc_utmi_phy_enable_sleepwalk : port 1, speed 1
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.244210] tegra-pmc: PMC tegra_pmc_utmi_phy_enable_sleepwalk : port 2, speed 3
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.245695] tegra-xusb-padctl 7009f000.xusb_padctl: power down UTMI pad 1
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.245749] tegra-xusb 70090000.xusb: entering ELPG done
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.247668] tegra_cec 70015000.tegra_cec: suspended
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.252615] sdhci-tegra sdhci-tegra.0: Tuning done, restoring the best tap value : 19
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.269704] tegradc tegradc.0: suspend
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.278785] extcon-disp-state extcon:disp-state: cable 47 state 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.278788] Extcon AUX1(HDMI) disable
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.333072] PM: suspend of devices complete after 191.133 msecs
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.334689] host1x 50000000.host1x: suspended
ov 23 22:09:34 usepit-usage-pit kernel: [ 4811.334834] PM: late suspend of devices complete after 1.753 msecs
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.337482] PM: noirq suspend of devices complete after 2.637 msecs
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4811.337494] PM: suspend-to-idle
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4857.525046] PM: resume from suspend-to-idle
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4857.528866] tegra-pcie 1003000.pcie: probing port 0, using 4 lanes
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4857.530999] tegra-pcie 1003000.pcie: probing port 1, using 1 lanes
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4857.955632] tegra-pcie 1003000.pcie: link 0 down, retrying
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.358934] tegra-pcie 1003000.pcie: link 0 down, retrying
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.762406] tegra-pcie 1003000.pcie: link 0 down, retrying
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.763444] tegra-pcie 1003000.pcie: link 0 down, ignoring
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.868825] tegra-xusb 70090000.xusb: exiting ELPG
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.869226] tegra-xusb-padctl 7009f000.xusb_padctl: power on UTMI pads 2
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.870195] tegra-xusb-padctl 7009f000.xusb_padctl: power on UTMI pads 1
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.872505] tegra-xusb 70090000.xusb: Firmware timestamp: 2020-07-31 09:33:12 UTC, Version: 50.26 release
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.872762] tegra-pmc: PMC tegra_pmc_utmi_phy_disable_sleepwalk : port 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.872777] tegra-pmc: PMC tegra_pmc_utmi_phy_disable_sleepwalk : port 1
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.872792] tegra-pmc: PMC tegra_pmc_utmi_phy_disable_sleepwalk : port 2
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.873544] tegra-xusb 70090000.xusb: exiting ELPG done
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.873818] PM: noirq resume of devices complete after 1348.776 msecs
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.874913] host1x 50000000.host1x: resuming
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.876109] PM: early resume of devices complete after 1.648 msecs
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.876602] tegradc tegradc.0: resume
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887283] sdhci-tegra sdhci-tegra.0: Tuning done, restoring the best tap value : 19
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887394] sdhci-tegra sdhci-tegra.0: Tuning done, restoring the best tap value : 19
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887741] tegra_soctherm 700e2000.soctherm: thermtrip: will shut down when cpu reaches 102500 mC
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887748] tegra_soctherm 700e2000.soctherm: throttrip: will throttle when cpu reaches 100500 mC
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887750] tegra_soctherm 700e2000.soctherm: thermtrip: will shut down when gpu reaches 103000 mC
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887755] tegra_soctherm 700e2000.soctherm: throttrip: will throttle when gpu reaches 101000 mC
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887758] tegra_soctherm 700e2000.soctherm: thermtrip: will shut down when pll reaches 127000 mC
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887761] tegra_soctherm 700e2000.soctherm: throttrip: pll: missing hot temperature
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.887766] tegra_cec 70015000.tegra_cec: Resuming
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.892604] tegra_cec 70015000.tegra_cec: tegra_cec_init started
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.894752] extcon-gpio-states extcon:extcon@1: Cable state:0, cable id:0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.896343] tegra-xudc-new 700d0000.xudc: exiting ELPG
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.896985] tegra-xudc-new 700d0000.xudc: exiting ELPG done
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.896988] tegra-xudc-new 700d0000.xudc: vbus state: 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.968241] mt7601u 1-3.2:1.0: Error: MCU response pre-completed!
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.991228] mt7601u 1-3.2:1.0: EEPROM ver:0d fae:00
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4858.995203] tegradc tegradc.0: read_edid_into_buffer: extension_blocks = 1, max_ext_blocks = 3
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.010898] tegradc tegradc.0: hdmi_recheck_edid: read_edid_into_buffer() returned 256
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.010902] tegradc tegradc.0: old edid len = 256
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.010905] tegradc tegradc.0: hdmi: No EDID change after HPD bounce, taking no action
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.018757] tegradc tegradc.0: nominal-pclk:267810000 parent:267809375 div:1.0 pclk:267809375 265131900~291912900
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.018783] tegradc tegradc.0: hdmi: tmds rate:267810K prod-setting:prod_c_hdmi_150m_300m
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.019762] tegradc tegradc.0: hdmi: get YCC quant from EDID.
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.054453] extcon-disp-state extcon:disp-state: cable 47 state 1
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.054455] Extcon AUX1(HDMI) enable
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.101096] sdhci-tegra sdhci-tegra.0: Tuning done, restoring the best tap value : 19
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.200190] PM: resume of devices complete after 324.083 msecs
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.203576] PM: Finishing wakeup.
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.203579] Restarting tasks …
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.208924] usb usb2: usb_suspend_both: status 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.208942] tegra-xudc-new 700d0000.xudc: entering ELPG
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.209148] tegra-xudc-new 700d0000.xudc: entering ELPG done
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.209830] done.
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.209914] tegra_soctherm 700e2000.soctherm: soctherm: trip temperature -2147483647 forced to -127000
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.209935] tegra_soctherm 700e2000.soctherm: soctherm: trip temperature -2147483647 forced to -127000
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.209947] tegra_soctherm 700e2000.soctherm: soctherm: trip temperature -2147483647 forced to -127000
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.218772] tegra_dvfs: resumed
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.218831] PM: suspend exit 2021-11-24 03:09:34.397866216 UTC
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.564612] tegradc tegradc.0: blank - powerdown
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.620194] extcon-disp-state extcon:disp-state: cable 47 state 0
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.620196] Extcon AUX1(HDMI) disable
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.640382] tegradc tegradc.0: unblank
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.647869] tegradc tegradc.0: nominal-pclk:106500000 parent:106500000 div:1.0 pclk:106500000 105435000~116085000
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.647931] tegradc tegradc.0: hdmi: tmds rate:106500K prod-setting:prod_c_hdmi_75m_150m
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.648905] tegradc tegradc.0: hdmi: get YCC quant from EDID.
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.683657] extcon-disp-state extcon:disp-state: cable 47 state 1
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.683659] Extcon AUX1(HDMI) enable
Nov 23 22:09:34 usepit-usage-pit kernel: [ 4859.683823] tegradc tegradc.0: unblank
Nov 23 22:09:35 usepit-usage-pit kernel: [ 4859.899449] tegra_cec 70015000.tegra_cec: tegra_cec_init Done.
Nov 23 22:09:53 usepit-usage-pit systemd[1]: Starting Network Manager…
Nov 23 22:09:53 usepit-usage-pit NetworkManager[13342]: [1637723393.5333] NetworkManager (version 1.10.6) is starting… (after a restart)

etc, the reboot happens at 22:09:53 exactly 1m10s after the initial suspend. Seems strange to me that “Freezing remaining freezable tasks” and “Suspending system (freeze)” only occur at the 22:09:34 mark, seemingly when the system was being woken up, while the initial freeze was at 22:08:43-46.

hello user56846,

may I know what’s the platform’s environment? do you have thermal solutions?
please refer to Thermal Specifications, if you keep increasing the thermal, it’ll trigger SW throttling to reduce clock rates, finally the HW throttling to force shutdown the board in order to protect the chip.

Hello Mr. Chang, the platform is Jetpack 4.6/Jetson Nano 2gb/Ubuntu 18.04. I have the stock heatsink but I’m not going above 70 C at full load, and this is only happening when completely idle during suspend so I don’t think it’s related, though I did overclock to 2ghz as you can see. that message also happens like 10-15 seconds before the board actually reboots

edit: or did you mean physical environment? in any case it’s not overheating

please also have tegrastats Utility executed to gather the reported statistics.

sample of tegrastats just before a reboot:

RAM 722/1972MB (lfb 156x4MB) SWAP 0/5082MB (cached 0MB) IRAM 0/252kB(lfb 252kB) CPU [9%@1224,9%@1224,14%@1224,6%@1224] EMC_FREQ 2%@1600 GR3D_FREQ 0%@76 APE 25 PLL@35.5C CPU@40.5C PMIC@50C GPU@39C AO@43.5C thermal@40.25C
RAM 722/1972MB (lfb 156x4MB) SWAP 0/5082MB (cached 0MB) IRAM 0/252kB(lfb 252kB) CPU [14%@1836,8%@1836,5%@1836,4%@1836] EMC_FREQ 2%@1600 GR3D_FREQ 57%@153 APE 25 PLL@36C CPU@42C PMIC@50C GPU@39C AO@44C thermal@40.5C
RAM 722/1972MB (lfb 156x4MB) SWAP 0/5082MB (cached 0MB) IRAM 0/252kB(lfb 252kB) CPU [3%@1224,1%@1224,5%@1224,2%@1224] EMC_FREQ 2%@1600 GR3D_FREQ 27%@153 APE 25 PLL@36C CPU@41C PMIC@50C GPU@39C AO@44C thermal@40.5C
RAM 722/1972MB (lfb 156x4MB) SWAP 0/5082MB (cached 0MB) IRAM 0/252kB(lfb 252kB) CPU [19%@1734,15%@1734,27%@1734,12%@1734] EMC_FREQ 3%@1600 GR3D_FREQ 26%@153 APE 25 PLL@36C CPU@41C PMIC@50C GPU@39.5C AO@44C thermal@40.25C

I checked the log as well and the “soctherm thermtrip” was still there at these temperatures

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

hello user56846,

it’s weird, could you please setup a terminal and running $ dmesg --follow to keep capture the logs.
BTW, what’s the power-supply you’re using?