Recovering Xavier NX Dev Kit not booting anymore

Hi all,

I was busy doing some tests to setup a boot partition on a SSD, and after one graceful shutdown (to check if my stuff worked), the Xavier NX did not reboot properly. After gracefully shutting down I removed the SD card and tried booting it. Nothing happened on the screen connected to the Dev Kit so I assumed what I did did not work. I disconnected the power plug, put the SD card in the slot and powered the Xavier again, and the Xavier did not boot anymore at all since.
With a screen connected to the Xavier NX Dev Kit, I don’t see anything on screen (the screen doesn’t even “wake up” like when the Xavier normally start to boot). The green LED on the Dev Kit is shining, the heatsink heats up after a while but that’s all. No other sign of life.

I have tried connecting another screen, also using the Display port connector but nothing. I have tried connecting the dev kit to the network to see if I could ping it but nothing. I have tried another SD card with another version of the OS on it but nothing. I have also tried re-flashing an SD card fresh from the Nvidia website but nothing.

I have tried connecting the necessary pins on J14 to reset the Xavier but nothing. I have tried the shorting the pins for recovery mode on J14 but nothing. All this was done using the provided 19V power supply.
My Xavier NX is really not giving any sign of life anymore other than the LED and the temperature of the heatsink.

Does anyone know something that I could try to get it to boot again?

Thanks,
Nicolas.

Hi,

Actually, you didn’t try the real method to recover the system.
It sounds like you don’t know the true purpose of recovery mode. Recovery mode does not really “recover” something.

It is just put the board into the state that our flash tool is able to reflash it. The flash tool here is the sdkmanager.

SDKM is able to do the full re-flash to the board. However, sdcard image cannot. Thus, when you kept swapping the sdcard, it may not really resolve the possible issue.

Of course it still has chance to be a hardware problem. But we’ve seen a lots of similar cases as yours, so better trying sdkm first.

Hi! Indeed you were correct.
I downloaded the SDK Manager and went through the recovery process and I got my Xavier NX Dev Kit back up and running.
Thank you!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.