Remote access to Jetson over the internet

• Jetson Nano
• DeepStream Version 5.0
• JetPack Version 4.4

Hi all!

I was wondering if it was possible to access my Jetson over the internet. I tried installing Teamviewer and Anydesk but they don’t have any arm64 releases and the applications crash when you run them using amd (or other) versions. I tried VNC Connect but was only able to go as far as local remote access; they require full version purchase to access your host over the internet. I just need access to the terminal of my Jetson Nano. Is there a comprehensive guide (which covers all errors I may encounter) to do this? Thanks.

You can try using

Very simple to setup and you can attach the service to the ssh port and connect to it over networks. No inbound ports needed to be opened or port forwarding.

If you want graphical, try which has an arm version, can even use remoteit above to attach the service to port 4000. NOmachine doesn’t love gnome so either use a different desktop gui or just get a dummy hdmi plug or have a monitor attached

1 Like

also ngrok is convinient

1 Like