Remote Control over Internet of NVidia Jetson Nano

Dear NVidia-Fellows,
I’ve pretty much followed any advice to install either one of these remote control programs on my NVidia Jetson Nano:
-Teamviewer
-Nomachine
-Anydesk

Out of these, Anydesk won’t even start after installation but there’s also no reported case online that this has worked. Teamviewer crashes after a time of let’s say 10seconds but at least it kind of works. Nomachine successfully installs but shows no ‘global’ ip that I can connect to.

My question: has anyone of you successfully established a remote connection over internet to your NVidia Jetson Nano? Not over your local network.
Thank you a lot!

Hi,

We support vino as a remote desktop application. Have you tried it?

1 Like

I haven’t yet tried VINO, it seems like a good open-source VNC unlike RealVNC. I’ve checked on some tutorials:

The JetsonNano is not deployed in my local network but somewhere completely else. It gets it’s internet over a Huawei LTE Dongle, where it is not possible to set DNS.

However, I could try setting up OpenVPN and use NO-IP as a DNS service. Are there any confirmed posts that this works for remote access to the JetsonNano?
Thank you!

Hello,

Can I use the TeamViewer?

Thank you.