Use ngrok for accessing remote access on jetson

I have a client where I need to do some updates and support on a system running Ubuntu on jetson xavier nx. First I was thinking of using Teamviewer but it is not supporting arm64. The same scenario with google remote desktop and others …

I tried to use nomachine which works fine when running on the same network. I tried to make it work from outside (from the internet) by running it together with services like ngrok or localtunnel but it cant get it to work and I might misunderstand some of the concept. This is what I have done:

  1. installed nomachine and ngrok on Jetson
  2. run nomachine-service and start the server
  3. the server says nx://172.20.10.12 and ssh://172.20.10.12. It runs on port 4000

here comes what I might misunderstand. My idea is to use ngrok to fetch the nomachine so I can access it from a webpage from anywhere instead of running it from my another computer on the same network.

After I saved my accesstoken for ngrok I tried by typing:
./ngrok tcp 172.20.10.12:4000

But it didnt work.

Any idea how I can get this to work, basically to access my jetson from remote

Looks like this thread can help if you wan to use those server based solution.

We both have the same problem, it is easy to connect (/access) the nano with a computer connected to the same network. But Connecting it from a remote network (different network) is an issue that needs solving.
Hopefully Nvidia (or someone) releases a patch that will let us install RealVNC on Jetson platform, this will fix these problems.