Removing emmc partitions in nvme Flashed board

Hi Team,
I am using AGX Orin devkit flashed with L4T35.2.1. I flashed L4T35.2.1 to nvme ssd instead of emmc by following the steps in developer guide.

Used the suggested flash_l4t_external.xml file and updated the num-sectors as per the ssd connected to the board. I was able to flash and board is booting from SSD.

My doubt is, Will it cause any issue if i delete and remove the files and partitions from the emmc, as i will be using only SSD to boot the board in future?

Also when i use the flash command, where does the uefi gets flashed to?

lsblk output is attached. Let me know if you need any other information.

Thanks in advance,

There is QSPI memory on the module where the bootloader got flashed into.

1 Like

Hi @WayneWWW,
I am facing issue with flashing now.
NVME SSD was previously flashed with bootable image. EMMC partitions are removed.

Using the same command as earlier to flash to ssd.

But ssd flashing is failed with below error,

Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Waiting for target to boot-up...
Cleaning up...

Please find the attached UART log.
ssd_flash_log.txt (24.1 KB)

Ashik P

Your UART log is not completed… For example, I have no idea why it started at timestamp 6.8 but not in the beginning…

[    6.817613] nvdla 158c0000.nvdla1: initialized
[    6.819383] tegra-gpcdma 2600000.gpcdma: Adding to iommu group 3
[    6.820345] tegra-gpcdma 2600000.gpcdma: GPC DMA driver register 31 channels
[    6.820771] tegra-fuse-burn efuse-burn: shutdown limit check disabled
[    6.820947] tegra-fuse-burn efuse-burn: Fuse burn driver initialized
[    6.821354] serial-tegra 3100000.serial: Adding to iommu group 3
[    6.824936] 3100000.serial: ttyTHS0 at MMIO 0x3100000 (irq = 13, base_baud = 0) is a TEGRA_UART
[    6.834093] serial-tegra 3110000.serial: Adding to iommu group 3
[    6.839576] 3110000.serial: ttyTHS1 at MMIO 0x3110000 (irq = 65, base_baud = 0) is a TEGRA_UART
[    6.848705] serial-tegra 3130000.serial: Adding to iommu group 3
[    6.854474] 3130000.serial: ttyTHS3 at MMIO 0x3130000 (irq = 66, base_baud = 0) is a TEGRA_UART

Initial logs were overwritten with the latest logs during the boot. i couldnt capture it.

Then try to learn how to let serial console log saved to a file directly…

It is a common sense to provide completed log…

Attached complete log,
ssd_log.txt (92.6 KB)

It looks like you customize the dtb. Is it a custom board or devkit?

It is nvidia devkit. dtb updated for an adapter board connected to the devkit.

One question. If you use sdkmanager to flash your board to nvme, will it work?

I don’t really care about what adapter for now. If it is devkit, use pure sdkmanager image first.

It will prove whether your host PC can use initrd flash or not.

Same behaviour is seen if i use the default nvidia image also. Please find the log.
ssd_log_nvidia.txt (88.1 KB)

I will try with sdk manager and let you know


Please also test with rel-35.4.1 instead of rel-35.2.1.

Hi @WayneWWW,
Tried flashing with sdkmanager with jetpack 5.1.2.
I could flash to emmc but failed to flash to nvme ssd.

Attached the logs,
Log while flashing to nvme ssd, (200.7 KB)
log while flashing to emmc, (151.4 KB)


Do you have other host PC that can test?

Also, just a common sense, you need to dump the uart log but not only the host log when you are checking flash problem.

There is no log in the UART side, other than the board booting to recovery mode.


Please read your own sdkmanager log… it says your host PC has package missing.

/home/ashik/nvidia/nvidia_sdk/JetPack_5.1.2_Linux_JETSON_AGX_ORIN_TARGETS/Linux_for_Tegra/tools/kernel_flash/ --no-flash --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_t234_nvme.xml --showlogs --network usb0 jetson-agx-orin-devkit nvme0n1p1
ERROR nfs-kernel-server not found! To install - please run: “sudo apt-get install nfs-kernel-server”

UART log will still have log during flash process…

If you don’t see it, it may indicate the flash process does not start.

Hi @WayneWWW,

Flashing to ssd fails with the same error as when i tried with the commands.

UART log:
r35.4.1_ssd_sdk_uartlog.txt (85.0 KB)
SDK Log: (580.3 KB)



Looks like sdkm falls into the same situation as previous manual flash.

One question here. Does this host ever flash any jetson orin nano/nx before?