Rendering error with AGX Xavier based embedded device


I am using an AGX Xavier based embedded device and installed ROS2 humble from source on Ubuntu 20.04. When I try to launch Rviz2, I get a rendering error pointing to OpenGL library. I initially was able to launch Rviz2 successfully when I had Jetpack 5.0.2 based BSP but after I flashed Jetpack 5.1 based BSP, I notice this error. Has anyone faced this issue and managed to resolve it or know any way to resolve it?
The error is as below:

Thanks in advance!

Please try the commands:

$ DISPLAY=:0 gst-launch-1.0 videotestsrc ! nv3dsink
$ DISPLAY=:0 gst-launch-1.0 videotestsrc ! nvvidconv ! nvegltransform ! nveglglessink

The two render plugins are based on GL/EGL. Would like to know whether the plugins work or not. Please give it a try.


Thanks for the response.
I tried out the commands you shared and see errors returned for both as seen in the image attached.
Is there a way to install the required drivers/packages to resolve this?


Please clean the cache and check if nvvidconv plugin:

$ rm .cache/gstreamer-1.0/registry.aarch64.bin

The plugin should be present. It is not expected it is missing. If cleaning the cache does not help, we would suggest re-flash the system to Jetpack 4.6.3 or 5.1.1

Hi @DaneLLL ,

It seems like the plugin does not exist when tried after clearing the cache. Could you please confirm this with the screenshot below?
Is there another way to install these plugins without re-flashing?

Thank you


Wanted to provide an update to this thread.
I was able to resolve this issue by re-flashing Jetpack 5.1.

Thank you

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.