Report of Success in Ubuntu 9.04

Hello to all,

In order to have CUDA running properly in Ubuntu 9.04 (or Kubuntu 9.04), try to use the following drivers and SDK: or

Also, set the following environment variables in ~/.bashrc:


export PATH
export LD_LIBRARY_PATH[/b]

Hope it helps. I wasted all my day trying to figure out why the 2.3 version that NVIDIA released do not work in my system. If someone was able to run the 2.3 version on Ubuntu 9.04, please post here.

I run 9.04 on my machine at the office with no problems… what issues have you seen?

I have been having a lot of problems with the 190.16 beta driver to work on my M1730 Dell laptop running a fresh version of Ubuntu 64 bit 9.04. I haven’t successfully been able to install anything over the 180.44 driver, which I am still unsure what the compatibility issue is.

when I load the driver the system will hang, and ultimately I have too boot in fail safe mode

I could build all the SDK projects, but when I tried to execute the executable file, an error occurred. It could not load

Try out the 190.18 beta driver.


I would like to reiterate this problem report. I am running Kubuntu Jaunty Jackal and I installed the driver, toolkit and sdk. I was unable to compile the toolkit. I am positive that my paths are set up correctly. I will now revert to the versions for Ubuntu 8.10.

make[1]: Entering directory `/mnt/glow/home/dream/mingus/cuda/C/src/marchingCubes'

/usr/bin/ld: cannot find -lcudart

collect2: ld returned 1 exit status

make[1]: *** [../../bin/linux/release/marchingCubes] Error 1

make[1]: Leaving directory `/mnt/glow/home/dream/mingus/cuda/C/src/marchingCubes'

make: *** [src/marchingCubes/Makefile.ph_build] Error 2


After switching back to the previous versions everything is working.

your LD_LIBRARY_PATH is set incorrectly.

False. And I’ve already given you enough information to deduce that - were it set incorrectly the previous version would not work either.

You should probably try:

sudo apt-get install freeglut3 freeglut3-dev

and optionally a:

sudo apt-get install freeglut3-dbg

I use CUDA 2.3 on Ubuntu 9.04 x86_64 and did set the LD_LIBRARY_PATH to:


(As you can see I use the ifort comiler for FORTRAN code.) Russel Nurjew.