(Resolved)Jetson-tk1 USB micro-B cable cannot connect to Windows 7 host, the device driver APX canno

I have bought a Tegra jetson-tk1 board.I want to flash rootfs including the uboot and kernel image I built onto the system’s internal eMMC.
The host system is windows 7 with Ubuntu installed in Virtualbox.At last it shows that:
Nvflash 4.13.0000 started
USB device not found
Failed flash ardbeg

From device manager, there is unknow USB device, the APX driver cannot be install.
Where could find the NVIDIA USB Boot recovery driver for Mobile devices?
The downloaded APX driver all cannot be installed.

Is the Jetson in ‘force recovery’ mode? With the board off:

Connect the Jetson to your host machine.
Hold down the ‘force recovery’ button while pressing the power button. Then release the recovery button after 1 second.

In the Ubuntu VM, does the ‘lsusb’ command show a device connected called “NVidia Corp.”? If it does, you should be all set.

You need to do this without the virtual machine then the instructions will work.

Thanks for your reply. Yes, I have put jetson into “force recovery mode”, but in Ubuntu VM there is no USB device called “Nvidia Corp”. In Device manager there is an “APX” with excalmatory mark in “Other device”.

.

Do you mean that this instruction cannot work on Virtual machine? Is there any way to make it work on a windows host with virtual machine? Thank you!

Is there any APX driver can be installed? Or nvidia usb boot recovery driver for mobile device? It seems that the APX device cannot be recognized.

https://www.virtualbox.org/manual/ch03.html#idp54668304
you need to use the usb ‘passthrough’ feature on virtual box.

VMWare Player (i think that is the free version) also has this feature and is as simple as clicking ‘connect to VM’ and its done

I use a VM for all my flashing and have encountered no issues yet.

Thanks for your help! It works now. I set filter for the USB device and add my account to vboxusers in Virtualbox.

Problem while connecting Jetson with Windows Host with VM(Ubuntu 14.04)

When I connect my Micro B USB cable to a Windows Host with VirtualBox (UBUNTU 14.04) there is no status as connected (in Windows) or the lsusb command shows Nvidia corp.

  • also tried with VMplayer same problem
  • I could not add filter in VirtualBox. If I insert a pendrive I could add usb filter because it is detected and it shows while adding the filter but I couldn’t do the same with my Jetson TK1 Board.

One point to clarify is that the micro-B USB supplied with Jetson only works for flash, and will still not show up unless the Jetson is in recovery mode. The recovery button must be held down as power is applied to reach recovery mode. In no other case will the micro-B cable have any use.

Thank for your reply. Now it is working fine.

All of the above seems related to what I need but I dont know how to go about it.
First of all I dont know how to power the jetson tk1 down when connected to my laptop.
IP address not found
I am using Ubuntu 14.04 on virtual box with Windows 8.1 as the host system.
I’ve installed jetson tk1 kit on my system and I am now at the stage of force recovery mode; I connected the jetson tk1 to the system, followed the routine of force recovery mode, the set-up/installation process started but it didn’t totally follow through but input device information dialog box popped up and I inputed the default user name and password but the I don’t know how to get the required IP address. I checked online and I saw a default IP address but it didn’t work, I tried to force it on my Ubuntu OS in virtual box through the code: but it was not successful, I checked the Ip addresses on the Ubuntu 14.04 but it was still not there; yet when I checked host system: Windows 8.1, I saw Apk device that needed be troubleshooting, I tried troubleshooting but it claims that it does not have the required driver. I totally don’t know what to do next.

Jetson is like any other device you connect to your network, it’s uses DHCP to get an IP from your network.

You can check the IP from your network’s DHCP server (maybe some WIFI router or similar?) or you can connect keyboard and a display to Jetson, log in and check the IP with “ifconfig” command. Or you can use the serial cable to login to Jetson and use the same “ifconfig” command.

Thanks, but it’s still not working. I think the main issue is “USB not found”, I tried following the steps on : https://cyclicredundancy.wordpress.com/2014/05/10/flashing-the-rootfs-on-a-nvidia-jetson-tk1/

but while trying to run sudo ./flash.sh -S 8GiB jetson-tk1 mmcblk0p1 the process started but at a point stopped and showed:
Nvflash 4.13.0000 started
USB device not found
Failed flashing ardbeg.