recovery jetson tk1 :'failed device ardbeg'

after the following code excuting,
“sudo ./ -S 8GiB jetson-tk1 mmcblk0p1”

It comes with
" USB device not found
Failed flashing ardbeg."

what should i do to deal with this issue?
thanks very much!

The program uses the USB ID to find a recovery mode Jetson. In the case of jetson-tk1, it looks for whether there is a response from:

lsusb -d 0955:7140

If you have the Jetson in recovery mode, and the micro-B USB cable connected to your host, then on the host you should be able to run the above command and see this. What happens when your Jetson is connected in recovery mode and you run the command?

Btw, I’d suggest using more than 8GiB unless you have a good reason. If you want to fully use the partition, then use “-S 14580MiB”.

Hi, Linuxdev

Thanks for your answer.

I ran the command ‘lsusb -d 0955:7140’ under the recovery mode, and there was no response for it. I also tried “-S 14580MiB”, but it didn’t work either, still " USB device not found. Failed flashing ardbeg."
I’m sure my jetson tk1 have been connected to my host.

Could you tell me what should I do? Looking for your reply.


The Jetson must be in recovery mode for it to show up, and the micro-B connector must be used. The supplied cable would be recommended.

Are you sure it was in recovery mode? Basically, anything that turns on power while the recovery button is held down should do this; from power off, hold down recovery, tap power; or with power on, hold down recovery, tap reset button. When this happens the Jetson becomes a programmable device on USB (instead of being a computer on its own). Do note that the wrong cable type will fail (either the full-sized connector or a type-A micro would fail…only micro-B works).