Jetson TK1 micro USB not working

hello all,

I want to install L4T in my jetson tk1, but unfortunately, when I connect my board to my PC through USB to micro USB , the PC did not recognize it at all. I tried to connect it to window and Linux but still not working


The supplied cable is a type B micro USB cable…this works for flash. If you use a different cable be sure it isn’t type A. Type A is useful when the Jetson is not in recovery mode…in that case the connector turns into a regular USB port for mice, keyboards, so on.

The Jetson itself does not show up unless you have it in recovery mode. The recovery button has to be held down while the power is applied or reset. There is no time length requirement, just hold down the reset button, then tapping reset button (if already on), or plugging in power (if not plugged in), or tapping the power button (if plugged in but off) will do the job. You can let go of the recovery button immediately after applying or resetting power.

I guess the board was not in recovery mode. Keep tapping the recovery botton and then power on the board,and then the board will get into recvoery mode

So long as the recovery button is held down at the moment power comes up (or the moment the reset key is tapped) you should not have to bring up power more than once (no tapping required). There are some TX1’s which may require this (that’s a special case issue with a capacitor), but I’ve not heard of a TK1 doing that.