Jetson TX1 not getting recognised in lsusb command

Hi,
I tried to enable USB 3.0 by following steps in https://devtalk.nvidia.com/default/topic/952472/jetson-tx1/jtx1_usb_as-device/post/5200923/#5200923 but unfortunately some issue happened and now Microusb port is not functioning(keyboard,mice nothing works now in port).Even I tried to flash jetson but board is not getting recognized in host computer (lsusb command in recovery mode with cable provided in kit). Can someone help me please to solve this issue.PFA for dmesg out
Thanks in advance
dmesg.txt (60.5 KB)

The micro-OTG port is not capable of USB3, the required wiring does not exist, and that connector cannot be used with USB3 standards.

The micro-OTG port should still work for flash, but only if the Jetson is in recovery mode. Other changes to the running operating system should have no effect on recovery mode. Are you sure the unit is in recovery mode and the micro-B USB cable when you use lsusb from the host PC? Also, is the host PC a VM? VMs tend to fail to handle USB correctly.

Hi,
Entering recovery mode is a hardware function. It shall always work when you ground recovery pin and give reset pulse. Please check section 11.6 in design guide:
http://developer.nvidia.com/embedded/dlc/jetson-tx1-oem-product-design-guide

You may also try other OTG cable. If it still does not work, maybe the board is broken physically.

Hi,
I tried to boot into recovery mode by pressing recovery button and reset button and then released reset and recovery button as instructed in SDK setup procedure.I used the same micro USB provided by the manufacturer itslef and not using VM machine as host.

@Dane,
I am not able to figure out the E1 pin in Jetson TX1 board. Can you please help me to locate it in board
Thanks,
Hari

Hi,
It is probably the board is defective. Pressing force-recovery button grounds E1 pin. While pressing the button and then press reset button, it should go to recovery mode. If this does not work for you, you may need an RMA.
https://developer.nvidia.com/embedded/faq#rma-process