Problems when connecting to micro-USB on TX2 in recovery mode via forced-recovery


I am having a problem with using the micro-usb port on the TX2.

We have a development board integrated TX2, which has been packaged.

We want to update TX2’s system, the only way to enter the recovery mode is by the command line. When bringing the TX2 on our development board into force recovery mode from running system with:
sudo reboot --force forced-recovery

We use a host laptop to detect TX2’s micro-usb by:


But the “0955:7c18 NVidia Corp” sometimes is not available.

When it is available, we flashed the system by:

sudo ./ -r jetson-tx2 mmcblk0p1

But the flashing is always interrupted in somewhere like:

And the micro-usb port disappeared, we cannot see the “Nvidia crop” anymore.

Could this be a hardware issue on the development board? I would appreciate any help that you can offer.

Besides, our host laptop is of native ubuntu18 and usb3.0. And we used the supplied usb cable.

That does sound like a problem. When this fails at the Jetson side though it tends to be a 100% failure. When it is related to a USB connector, then it tends to have the behavior you describing. Does the laptop have a different port you can try? Or is there a different Ubuntu host PC you might be able to try (at least temporarily)?

Yes, we have tried all three usb3.0 ports on the host laptop.
In addition, we tried on another laptop with native ubuntu16 and a desktop with VM ubuntu16. We both tried three times.
They cannot detect the micro-usb either.

As a reference, we use the the official development board for the same operation, and all three computers can detect the micro-usb.

VMs are not supported, and have a very high rate of failure for this issue. VMs can be made to work, but they tend to fail to always pass the USB through to the VM. Any time a flash is going on the Jetson will be repeatedly disconnecting and reconnecting, and most of the time, unless you have performed additional setup, the parent o/s will keep the reconnect USB and not correctly pass through to child o/s.

Do you have a host you can test with which is native Ubuntu? Even if one Jetson worked with the VM there is a very strong chance that you simply got lucky. With native Ubuntu installs (you could dual boot if you have enough disk space) you would be able to actually know there is a USB issue or not.

except for the first laptop with native Ubuntu18 and the second desktop with VM Ubuntu16, we test with another laptop with native Ubuntu16.
We still can’t detect the micro-usb on TX2.

I think if the following can be verified using a non-VM Linux (any flavor), then this is a hardware failure…

If the host PC monitors “dmesg --follow”, and TX2 is not powered, and the cable is then connected, followed by powering up the TX2 with recovery button held down, then you should see some sort of message from the dmesg.

Assuming this is a regular TX2 and not the industrial model (and perhaps even if it is industrial, but I don’t have one to verify), then after the recovery mode Jetson is connected via the provided micro-B USB, you should see some output from:
lsusb -d 0955:7c18

If both of those fail to provide an indication, then I think you can consider this hardware failure. Do be suspicious of laptop USB connectors, but probably having two laptops fail in the same way says it is a Jetson side failure.