Jetson Tx2 not being detected on host PC while flashing Jetpack.

I bought a Jetson tx2 online from the official Nvidia website. I was trying to flash the latest jetson image os using SDK manager, But the device is not shown on the host pc which is running ubuntu 16.04.
I even tried searching the device using lsusb but not found there as well.
The device is in force recover mode as there is no output on the HDMI screen, I have also connected the jetson via micro USB port to a USB 3.0 on the host pc.
I have followed all instruction as per the SDK manager but could not solve or identify the issue,
Need help with the same.

-Thanks in Advance

The HDMI won’t actually show anything during the flash, though it is useful to have it connected for other reasons. It does sound like you’ve done things correctly, but it is easy to double check (it beats an RMA if the RMA isn’t needed).

Just to verify, the TX2 has to have the force recovery button held down either as power is brought up, or as power is reset. There is no requirement to hold the recovery button for long periods of time, it’s just like a shift key for capital letters. If the actual cable you used was from the developer kit, and then different ports of the host PC cannot see the TX2 via “lsusb -d 0955:7c18”, then something is wrong. You might gain additional information if on your host you monitor “dmesg --follow” as you plug in the USB cable or as you put the unit in recovery mode.

Note that many third party cables are really only charger cables and not data cables, so this is why I want to be sure the cable itself is the one which shipped with the dev kit. Also, the host cannot be a VM since a VM has problems passing USB through correctly.

Go ahead and post what you find out from the above.

Thank You for reply
as per the steps you mentioned i proceeded accordingly after putting the device in recovery mode I used “dmesg --follow” and i received the following lines
[ 887.524826] usb usb1-port1: unable to enumerate USB device
[ 896.274544] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[ 897.434146] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[ 898.594004] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[ 899.753698] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[ 899.753741] usb usb1-port1: unable to enumerate USB device
[ 909.475595] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[ 911.259245] usb usb1-port1: Cannot enable. Maybe the USB cable is bad?
[ 1164.573555] usb 1-1: new high-speed USB device number 34 using xhci_hcd
[ 1164.714553] usb 1-1: New USB device found, idVendor=0955, idProduct=7c18
[ 1164.714561] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1164.714567] usb 1-1: Product: APX
[ 1164.714572] usb 1-1: Manufacturer: NVIDIA Corp.
[ 1165.042982] usb 1-1: USB disconnect, device number 34
[ 1971.070512] usb 1-4: USB disconnect, device number 5
I am using the usb cable provided in kit and i am not using a VM Either.
I am still not clear with what’s happening,I also connected a pendrive to the micro usb port on jetson and it was detected by the jetson.
Waiting for reply
Thank you.

I see a mix of bad messages, then normal messages about 4 minutes later. Is anything else sharing this port via a HUB? I’m wondering if you can try different ports and with and without a HUB…preferably nothing else sharing a HUB or port. Be careful to post only the log from the plugin event and not unplug, nor from previous to the plugin event. Basically I want to know what is going on specifically at the moment of plug.

Btw, if there is some other USB device with issues, then it can interfere with all other USB going to the same root HUB.