Jetpack 4.5.1 Linux for Jetson TX2 installation failed

I use SDKmanager1.6.0 on host ubuntu 18.04 to flash jetpack 4.5.1 on Jetson TX2 P3310-1000 module P2597-0000 carrier board,then I meet the problem.

I have successfully started the force recovery mode,completed the Ubuntu ‘System configuration wizard’ on Jetson TX2 and made sure that the device was connected to this host machine with a USB cable.

If I put TX2 on force recovery mode,the host command “lsusb” can detect tx2,the error is as below.

While when I normally start TX2 and logging in ubuntu,the host cannot detect tx2.

I tried to change the password to see if it worked, but it didn’t work.

Hi 1374360168,

Can you please open a terminal window on host machine, then try to ssh to Jetson TX2 with the same user name and password? Can you please show us the log for this ssh command?

Hi,I normally start TX2,log in ubuntu,and TX2 connects to a wifi.Maybe the problem is the IP address since I try to use “ssh chant@192.168.55.1” and “ping 192.168.55.1” command, both are failed,I cannot connect to TX2.

That 192.168.55.1 IP address requires the micro usb cable connected between your host and your TX2.

Please make sure you really connect it.

I’m quite sure I really connect the wire,because without touching the wire and board,I choose to start the board in force recovery mode,then the host terminal can detect TX2 by running “lsusb” command which shows 0955:7c18 [NVIDIA Corp].
3098870DEB4D7ACC23C23D4124EF5F68

While when not in force recovery mode,the host cannot detect TX2.
1FA2E03CB716581BA0542CC4F091333C

We do have some users hit a problem that their device is not able to launch usb device mode. Such problem seems due to the host side driver.

You can try different usb cable and even other hosts. If you don’t need such interface for installing the SDK, then just switch the IP to other interface that your host can access.

Can you ssh from the host to your Jetson device WIFI IP address? If yes, can you please change the IP address to the WIFI IP address in the SDK Manager pop up dialog box?

No,I cannot ssh from the host to Jetson WIFI IP.I have tried all usb cable but this didn’t work.I just have one host with linux.

But what still puzzles me is that when I switch TX2 to force recovery mode, the host can detect the device. Does this mean that the USB port of TX2 is output by default instead of input in the normal boot mode.

It seems that the USB-device mode doesn’t work on Jetson TX2. Please see Wayne’s suggestion above: Jetpack 4.5.1 Linux for Jetson TX2 installation failed - #7 by WayneWWW

Thanks,I have successfully flashed the device. The reason for the error is that I used other usb cable instead of the supporting usb cable in the kit.I suggest that someone write this note in NV_ jetson_ tx2_ developer_ kit_ user_ guide.