RTSP stream drops quality at 60 FPS

I want to run an RTSP stream at 60FPS and 2560x720 resolution. This works fine as a direct output, however I think when I encode it, the resolution drops at 60FPS. Is there a way I can preserve the resolution at 60FPS because I know that the camera can handle that stream rate. Here is my pipeline:

./test-launch "v4l2src device=/dev/video2 do-timestamp=1 ! video/x-raw, width=2560, height=720, framerate=60/1 ! nvvidconv ! nvv4l2h264enc insert-vui=1 insert-sps-pps=1 ! h264parse ! rtph264pay name=pay0"

gst-launch-1.0 rtspsrc location=rtsp:// latency=0 ! application/x-rtp,media=video,encoding-name=H264 ! rtph264depay ! h264parse ! nvv4l2decoder ! nvvidconv ! xvimagesink

Please refer to this post for setting encoder properties:
Random blockiness in the picture RTSP server-client -Jetson TX2 - #5 by DaneLLL

To get balance between bitrate and quality, we would suggest run in CBR mode and adjust virtual buffer size.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.