RTX 2060 notebook

Hello I was wondering when the 2060 Max-Q will be supported. I recently purchased a razer blade rtx for development purposes and would love to take advantage of the hardware.

Thanks in advance.

Are you sure it’s a 2060 Max-Q? I don’t think that exists, at least even razer.com only lists
2060 (min. driver 415.27)
2070 Max-Q (min. driver 418.30)
2080 Max-Q (min. driver 418.30)

It was on the Microsoft store they labelled it incorrectly, either way I have not found a driver that works with it.

Which distribution are you using?
What’s the output of
sudo lspci -nn -d 10de:*

Sorry should have added that. Ubuntu 18.04.

Here is the output.

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1f11] (rev a1)
01:00.1 Audio device [0403]: NVIDIA Corporation Device [10de:10f9] (rev a1)
01:00.2 USB controller [0c03]: NVIDIA Corporation Device [10de:1ada] (rev a1)
01:00.3 Serial bus controller [0c80]: NVIDIA Corporation Device [10de:1adb] (rev a1)

Thanks for helping out, I tried a few drivers but none really worked (415, 418).

The 2060 with your PCI ID (10de:1f11) is indeed only supported by the 418 driver: https://download.nvidia.com/XFree86/Linux-x86_64/418.43/README/supportedchips.html
So a driver exists but so far that is not yet in Ubuntu’s graphics ppa. https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Since this is probably an Optimus (hybrid graphics) notebook, using the .run installer is not recommended. You could try 418.43 driver from the staging ppa:
https://launchpad.net/~mamarley/+archive/ubuntu/staging
Otherwise, you’ll have to wait for it to show up in the regular ppa.

Thanks for the help, I switched to the staging ppa and worked like a charm.

I was using the .run before.

Cheers
From one happy dev :)

I have a similar output as xkludge for my rtx 2060 on ubuntu 18.04. I was using the 430 driver but switch to the 418 driver after seeing this post. I did the lspci and still have the same output. Is that expected? e.g. lspci will not show RTX 2060 as a result (shows 1f11 rev a1) even if RTX 2060 is shown on the “details” screen?

lspci just displays entries from the pcidb and you have obviously an older version installed. Doesn’t have anything to do with the driver or function. No need to worry.